1 Reply Latest reply on May 13, 2010 2:25 PM by Tom Fank

    Issues with Hibernate Search 3.2.0.CR1 and Seam 2.2.1.CR1

    Tom Fank Newbie

      The new proxied persistence provider (introduced in Seam 2.2.1.CR1) might need some rework in order to be compatible with the current release candidate of Hibernate Search (that is 3.2.0.CR1)...


      1)
      When org.jboss.seam.persistence.HibernatePersistenceProvider is trying to find out if HSearch is available it expects org.hibernate.search.Version to have some static VERSION field, but current release 3.2.0.CR1 does not provide it.


      2)
      The org.jboss.seam.persistence.HibernateSessionInvocationHandler does not seem to respect the org.hibernate.event.EventSource interface of the delegated Hibernate session. But the (legacy) implementation of FullTextSession still relies on it, so invocations of methods like ('getActionQueue') need to be handled correctly.


      Not sure if these should be fixed in Seam or HSearch...!?



      Tested on:
      JBoss AS 6.0.0.M2
      Hibernate 3.5.1
      Hibernate Search 3.2.0.CR1
      Seam 2.2.1.CR1