3 Replies Latest reply on May 3, 2010 3:15 PM by William Woodman

    logger not expanding attribute data in output

    William Woodman Master

      weird problem


      I am using works laptop and home pc some do some dev.


      i am using as5.1/seam 2.2.1 (or 2.2.0) and eclipse and jboss tools.


      at work latop my log.xx does not expand in the output but does at home


      heres a very simple example



      public class WilltestBean implements Willtest
      {
          @Logger private Log log;
      
          @In StatusMessages statusMessages;
      
          public void willtest()
          {
              // implement your business logic here
              log.info("willtest.willtest() action called #0", "extra text");
              statusMessages.add("willtest");
          }
      
          // add additional action methods
      
      }
      



      at work this produces


      18:04:23,769 WARN  [InterceptorsFactory] EJBTHREE-1246: Do not use InterceptorsFactory with a ManagedObjectAdvisor, InterceptorRegistry should be used via the bean container
      18:04:23,769 WARN  [InterceptorsFactory] EJBTHREE-1246: Do not use InterceptorsFactory with a ManagedObjectAdvisor, InterceptorRegistry should be used via the bean container
      18:04:23,769 INFO  [WilltestBean] willtest.willtest() action called #0
      



      where i just get #0 printed in the text - no expansion, but at work this works fine


      I have rebuilt my env at work with new eclipse/tools/jboss/seam and i still get same problem.


      only difference i can see is that at home i'm on windows 7 and work xp sp3.


      any idea whats going on its weird