2 Replies Latest reply on May 26, 2010 10:20 AM by Steph Applesauce

    Unable to deploy JBoss Web Service in separate EJB project

    Steph Applesauce Newbie

      Hi,


      I have succeeded in making a Mavenized configuration with Seam which is deployed as an EAR with the following structure:





      EAR




      • IHM project (odma-ihm) (WAR packaging)




      • Business project (odma-ejb) (EJB packaging)




      • Web Services project (odma-ws) (EJB packaging)




      • some common JAR packaged projects









      All works well. Unfortunately, I don’t succeed in deploying the Web Service. Hereunder, the structure of my Web Services project:





      JAR

      com/some/package/hierarchy/

       

      • ODMAWebService.class



       

      • IODMAWebService.class



      META-INF

       

      • ejb-jar.xml



       

      • MANIFEST.MF



       

      • seam.properties



       

      • standard-jaxws-endpoint-config.xml



      component.properties





      Hereunder, the content of some of this files:


      ODMAWebService:



      @Stateless
      @WebService(name = "ODMA-WS", serviceName = "ODMA-WS", targetNamespace="urn:odma:web-service")
      @SOAPBinding(parameterStyle = SOAPBinding.ParameterStyle.BARE)
      public class ODMAWebService implements IODMAWebService {
          @WebMethod(operationName = "InscriptionLivraisonRequest")
          @WebResult(name = "InscriptionLivraisonResponse")
          public InscriptionLivraisonResponse inscriptionLivraisonRequest(InscriptionLivraisonRequest request) throws Exception {
              …
          }
      }





      IODMAWebService:



      @WebService
      @Remote
      public interface IODMAWebService {
          …
      }





      ejb-jar.xml:



      <?xml version="1.0" encoding="ASCII"?>
      <ejb-jar xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:ejb="http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/ejb-jar_3_0.xsd" version="3.0">
          <display-name>odma-ws</display-name>
      </ejb-jar>





      standard-jaxws-endpoint-config.xml:



      <jaxws-config xmlns="urn:jboss:jaxws-config:2.0" 
                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                    xmlns:javaee="http://java.sun.com/xml/ns/javaee"
                    xsi:schemaLocation="urn:jboss:jaxws-config:2.0 jaxws-config_2_0.xsd">
         <endpoint-config>
            <config-name>Seam WebService Endpoint</config-name>
            <pre-handler-chains>
               <javaee:handler-chain>
                  <javaee:protocol-bindings>##SOAP11_HTTP</javaee:protocol-bindings>
                  <javaee:handler>
                     <javaee:handler-name>SOAP Request Handler</javaee:handler-name>
                     <javaee:handler-class>org.jboss.seam.webservice.SOAPRequestHandler</javaee:handler-class>
                  </javaee:handler>
               </javaee:handler-chain>
            </pre-handler-chains>
         </endpoint-config>
      </jaxws-config>





      And my application.xml:



      <?xml version="1.0" encoding="UTF-8"?>
      <application xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/application_5.xsd" version="5">
        <display-name>ODMA</display-name>
        <module>
          <ejb>odma-ejb.jar</ejb>
        </module>
        <module>
          <ejb>jboss-seam-2.2.0.GA.jar</ejb>
        </module>
        <module>
          <web>
            <web-uri>odma-ihm.war</web-uri>
            <context-root>odma</context-root>
          </web>
        </module>
        <module>
          <ejb>odma-ws.jar</ejb>
        </module>
        <module>
          <java>odma-common-ws-objects.jar</java>
        </module>
        <module>
          <java>odma-core.jar</java>
        </module>
        <module>
          <java>odma-common-errors.jar</java>
        </module>
        <library-directory>lib</library-directory>
      </application>



      Any idea would be appreciated.


      Thanks for taking time for looking at.

        • 1. Re: Unable to deploy JBoss Web Service in separate EJB project
          Gabor Jakab Newbie

          Do you have some symptoms or logs? Your odma-ws.jar should be set as an ejb module in your application.xml descriptor isn't it?

          • 2. Re: Unable to deploy JBoss Web Service in separate EJB project
            Steph Applesauce Newbie

            Unfortunately, I don't get many symptoms or logs. It's a pity because it would gave me a clue on the origin of the problem. Hereunder, some logs concerning JBoss Web Services startup and odma-ws deployment:




            10:09:51,595 INFO  [org.jboss.wsf.stack.jbws.NativeServerConfig]  JBoss Web Services - Native
            10:09:51,595 INFO  [org.jboss.wsf.stack.jbws.NativeServerConfig]  jbossws-3.0.1-native-2.0.4.GA (build=200803312044)
            […]
            10:09:56,164 INFO  [org.jboss.web.tomcat.service.TomcatDeployer]  deploy, ctxPath=/jbossws, warUrl=.../deploy/jbossws.sar/jbossws-context.war/
            […]
            10:10:21,043 INFO  [org.jboss.ejb3.EJBContainer]  STARTED EJB: com.macif.odma.session.ws.InscriptionLivraisonService ejbName: InscriptionLivraisonService
            10:10:21,056 INFO  [org.jboss.ejb3.EJB3Deployer]  Deployed: file:/media/DATA/ExDonnees/Workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_4.2_Runtime_Server/deploy/odma-ear.ear/odma-ejb.jar/
            10:10:21,213 INFO  [org.jboss.ejb3.JmxKernelAbstraction]  creating wrapper delegate for: org.jboss.ejb3.stateless.StatelessContainer
            10:10:21,222 INFO  [org.jboss.ejb3.JmxKernelAbstraction]  installing MBean: jboss.j2ee:ear=odma-ear.ear,jar=odma-ws.jar,name=ODMAWebService,service=EJB3 with dependencies:
            10:10:21,240 INFO  [org.jboss.ejb3.EJBContainer]  STARTED EJB: com.macif.odma.ws.endpoint.ODMAWebService ejbName: ODMAWebService
            10:10:21,318 INFO  [org.jboss.ejb3.EJB3Deployer]  Deployed: file:/media/DATA/ExDonnees/Workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_4.2_Runtime_Server/deploy/odma-ear.ear/odma-ws.jar/
            […]





            For my application.xml, as you can see in my first post, all seems good;




              […]
              <module>
                <ejb>odma-ws.jar</ejb>
              </module>
              […]




            Here the result of http://localhost:8080/jbossws/services:





            There are currently no endpoints deployed.



            Thanks for your help.