1 Reply Latest reply on Jun 28, 2010 6:12 PM by Daniel Hinojosa

    jboss seam web app throws errors for unkown reasons

    Daniel Kim Newbie
      Hi,

      I deployed jboss  seam web app that collects data from users and generates PDF reports. It is a relatively simple web app and it went fairly for 1st quarter. However we are having some issues for 2nd quarter.

      Some users are  experiencing log in problem(users see "something bad happened." jboss error messages) and some pages throws jboss error messages as well.
      When I checked log file, all I see is some buch of this error message:

      68.93.192.64 - - [28/Jun/2010:10:03:40 -0400] "GET /error.seam?cid=195  HTTP/1.1" 302 -

      However, when I tested production site I didn't get any problem for log in. However, I saw jboss error messages on some pages occassionally, but if I logout/login then try again, it worked fine. So, I thought it was some sort of glithces, but it looks like some users are having more severe problems.

      IE causes the problem the most and google Chrome gives the least issues.

      I think it is more like configuration issues.

      Here is the web.xml

      +++++++++++++

      <?xml version="1.0" ?>
      <web-app xmlns="http://java.sun.com/xml/ns/javaee"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
         version="2.5">



         <!-- RichFaces -->



         <context-param>
            <param-name>org.richfaces.SKIN</param-name>
            <param-value>deepMarine</param-value>
         </context-param>



         <!-- Suppress spurious stylesheets -->



         <context-param>
            <param-name>org.richfaces.CONTROL_SKINNING</param-name>
            <param-value>disable</param-value>
         </context-param>



         <context-param>
            <param-name>org.richfaces.CONTROL_SKINNING_CLASSES</param-name>
            <param-value>disable</param-value>
         </context-param>



         <!-- Change load strategy to DEFAULT to disable sending scripts/styles as packs -->



         <context-param>
            <param-name>org.richfaces.LoadStyleStrategy</param-name>
            <param-value>ALL</param-value>
         </context-param>



         <context-param>
            <param-name>org.richfaces.LoadScriptStrategy</param-name>
            <param-value>ALL</param-value>
         </context-param>



         <!-- Seam -->



         <listener>
            <listener-class>org.jboss.seam.servlet.SeamListener</listener-class>
         </listener>



         <filter>
            <filter-name>Seam Filter</filter-name>
            <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>
         </filter>



         <filter-mapping>
            <filter-name>Seam Filter</filter-name>
            <url-pattern>/*</url-pattern>
         </filter-mapping>



         <servlet>
            <servlet-name>Seam Resource Servlet</servlet-name>
            <servlet-class>org.jboss.seam.servlet.SeamResourceServlet</servlet-class>
         </servlet>



         <servlet-mapping>
            <servlet-name>Seam Resource Servlet</servlet-name>
            <url-pattern>/seam/resource/*</url-pattern>
         </servlet-mapping>



         <!-- Facelets development mode (disable in production) -->



         <context-param>
            <param-name>facelets.DEVELOPMENT</param-name>
            <param-value>false</param-value>
         </context-param>





         <!-- JSF -->



         <context-param>
            <param-name>javax.faces.DEFAULT_SUFFIX</param-name>
            <param-value>.xhtml</param-value>
         </context-param>



         <servlet>
            <servlet-name>Faces Servlet</servlet-name>
            <servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
            <load-on-startup>1</load-on-startup>
         </servlet>



         <servlet-mapping>
            <servlet-name>Faces Servlet</servlet-name>
            <url-pattern>*.seam</url-pattern>
         </servlet-mapping>



         <security-constraint>
            <display-name>Restrict raw XHTML Documents</display-name>
            <web-resource-collection>
               <web-resource-name>XHTML</web-resource-name>
               <url-pattern>*.xhtml</url-pattern>
            </web-resource-collection>
            <auth-constraint/>
         </security-constraint>



         <!-- uncomment <ejb-local-ref> entries when deploying to GlassFish and (optionally) JBoss AS 5 -->



         <!--



         <ejb-local-ref>



            <ejb-ref-name>kelc/AuthenticatorBean/local</ejb-ref-name>



            <ejb-ref-type>Session</ejb-ref-type>



            <local-home/>



            <local>com.mydomain.kelc.action.Authenticator</local>



         </ejb-local-ref>



         -->







         <!-- Add entries for each EJB session bean which is also a Seam component (not required on JBoss AS) -->







         <persistence-unit-ref>



            <persistence-unit-ref-name>kelc/pu</persistence-unit-ref-name>



            <!-- The relative reference doesn't work on GlassFish. Instead, set the <persistence-unit-name> to "kelc",



                 package persistence.xml in the WAR, and add a <jar-file> element in persistence.xml with value "../../kelc.jar". -->



            <persistence-unit-name>../kelc.jar#kelc</persistence-unit-name>



         </persistence-unit-ref>







      </web-app>



      +++++++++



      and this faces-config.xml



      ++++++++++++



      <?xml version='1.0' encoding='UTF-8'?>
      <faces-config version="1.2"
                    xmlns="http://java.sun.com/xml/ns/javaee"
                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-facesconfig_1_2.xsd">



         <application>
            <locale-config>
               <default-locale>en</default-locale>
               <supported-locale>bg</supported-locale>
               <supported-locale>de</supported-locale>
               <supported-locale>en</supported-locale>
               <supported-locale>fr</supported-locale>
               <supported-locale>it</supported-locale>
               <supported-locale>tr</supported-locale>
            </locale-config>
            <view-handler>com.sun.facelets.FaceletViewHandler</view-handler>
         </application>



      </faces-config>



      +++++++++++++



      I am using jboss jboss-4.2.3.GA.



      Thanks in advance

      Daniel