3 Replies Latest reply on Jul 9, 2010 4:46 AM by Francois Lagoueyte

    basic jpdl-pageflow problem

    Piet Miller Newbie

      Hi all,


      I got a pretty basic problem with my jpdl test-pageflow. The problem is, that it just won't work :).
      That means, when I click on my Button - this one...



      <h:commandButton id="buttonID" action="nextstep" value="next step"/>


      (from startpage.xhtml in the view directory)


      ...it loads for a moment but just stays on the same page.




      I will now write you everything I did - step by step:



      First I created a project-skeleton with seam-gen. The project will be deployed on a JBoss 5.1 AS.


      Then I created a pageflow.jpdl.xml in the resources folder:



      <pageflow-definition xmlns="http://jboss.com/products/seam/pageflow"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation=http://jboss.com/products/seam/pageflow http://jboss.com/products/seam/pageflow-2.2.xsd"
      name="testPageFlow">   
          <start-page name="startpage" view-id="/startpage.xhtml" back="disabled">
               <redirect/>
              <transition name="nextstep" to="next"></transition>
          </start-page>
      
          <page name="nextstep" view-id="/done.xhtml">
           <redirect/>
         </page>
      
      </pageflow-definition>



      (The done.xhtml also exists)



      Next I wrote this in the component.xml:



         <!-- For use with jBPM pageflow or process management -->
         <bpm:jbpm>
            <bpm:pageflow-definitions>
               <value>pageflow.jpdl.xml</value>
            </bpm:pageflow-definitions>
         </bpm:jbpm>
      





      ...wrote this in the pages.xml:


      <page view-id="/startpage.xhtml">
          <begin-conversation join="true" pageflow="testPageFlow"/>
       </page>




      I did nothing else...
      Did I miss anything?
      Did I put some files in wrong folders?


      I would really appreciate your help!





      *Piet