0 Replies Latest reply on Aug 13, 2010 3:03 AM by jerry scott2012

    SeamTest with TestNG problem under seam-gen project

    jerry scott2012 Newbie

          I'm a new comer towards seam. while in familiar with such great framework, I encountered some problem for testcase of SeamTest with TestNG problem under seam-gen project and hope friends of seam give me suggestions to solve such problem.


           First, Seam now I have used is the latest version(2.2.1 CR2) and I tried making some new project resort to the seam-gen command. After those done such project was imported due to the Eclipse3.6. with the help of the jboss-tools, I tried to create the class of seam conversation which left me the conversation class and also the testcase class for it with testng file matched.(the jdk edition is jdk1.5.0.22)


           Secondly, I installed the latest testng eclipse plugin which help me to execute the testng class(and the parent class is SeamTest) directly. but it was a pity that I couldn't pass wuch testcase under testng  with the error message listed in the console:
       
            Exception in thread main java.lang.NoClassDefFoundError: java.io.Console at org.testng.remote.RemoteTestNG.main(RemoteTestNG.java:127)
         
            So, If any of my friend in such forum encountered such problem while in SeamTest, would you mind giving your best advice on how to solve such problem. And I hope seam teamwork can make some better topics or articles to instruct us like me to make full use of SeamTest as Testing is very important under unit or integration testing.


                                                                                                  jerryscott