1 Reply Latest reply on Sep 13, 2010 1:46 AM by Neil C

    EL Error Deploying Seam 2 to Tomcat 6

    Neil C Novice

      I am deploying Seam 2.2.0.GA to Tomcat 6.0.28. This is really a lot tougher than I expected!


      After resolving the issue found here


      I got this one:




      java.lang.NoSuchMethodError: org.jboss.el.util.ReflectionUtil.startup()V
           at org.jboss.seam.el.JBossELReferenceCache.start(JBossELReferenceCache.java:18)



      Here is the Maven EL-related stuff I have:




             <dependency>
                  <groupId>org.jboss.el</groupId>
                  <artifactId>jboss-el</artifactId>
                  <version>2.0.1.GA</version>
                  <exclusions>
                      <exclusion>
                          <groupId>javax.el</groupId>
                          <artifactId>el-api</artifactId>
                      </exclusion>
                  </exclusions>
              </dependency>



      The exclusion is to avoid a LinkageError with Tomcat, another issue I had to figure out.


      Which EL should I use in order to work with Seam?


      Thanks.



        • 1. Re: EL Error Deploying Seam 2 to Tomcat 6
          Neil C Novice

          Indicentally, here are the jar files I have packaged in my war file:



          antlr-2.7.6.jar
          antlr-3.2.jar
          antlr-runtime-3.2.jar
          asm-3.1.jar
          cglib-2.2.jar
          commons-beanutils-1.8.3.jar
          commons-collections-3.2.1.jar
          commons-digester-2.0.jar
          commons-httpclient-2.0.2.jar
          commons-lang-2.4.jar
          commons-logging-1.1.1.jar
          concurrent-1.3.4.jar
          dom4j-1.6.1.jar
          hibernate-annotations-3.5.1-Final.jar
          hibernate-commons-annotations-3.1.0.GA.jar
          hibernate-core-3.5.1-Final.jar
          hibernate-entitymanager-3.5.1-Final.jar
          hibernate-jpa-2.0-api-1.0.0.Final.jar
          hibernate-validator-3.1.0.GA.jar
          javassist-3.8.0.GA.jar
          jboss-common-core-2.2.0.GA.jar
          jboss-common-logging-spi-2.0.4.GA.jar
          jboss-el-2.0.1.GA.jar
          jboss-seam-2.2.0.GA.jar
          jboss-seam-debug-2.2.0.GA.jar
          jboss-seam-jul-2.2.0.GA.jar
          jboss-seam-ui-2.2.0.GA.jar
          jsf-api-1.2.jar
          jsf-facelets-1.1.15.jar
          jsf-impl-1.2-b19.jar
          jta-1.1.jar
          log4j-1.2.16.jar
          primefaces-1.1.jar
          slf4j-api-1.6.1.jar
          slf4j-log4j12-1.6.1.jar
          stringtemplate-3.2.jar
          webdavlib-2.0.jar
          xml-apis-1.0.b2.jar
          xml-apis-2.7.1.jar
          xpp3_min-1.1.3.4.O.jar
          xstream-1.1.3.jar



          And here is what comes with Tomcat 6:




          annotations-api.jar     el-api.jar          servlet-api.jar
          catalina-ant.jar     jasper-el.jar          tomcat-coyote.jar
          catalina-ha.jar          jasper-jdt.jar          tomcat-i18n-es.jar
          catalina-tribes.jar     jasper.jar          tomcat-i18n-fr.jar
          catalina.jar          jsp-api.jar          tomcat-i18n-ja.jar
          



          As usual, it all looks right to me, but clearly the NoSuchMethodError means there is a mismatch somewhere. There are a ton of jboss-el jar files in the JBoss Nexus repository, and there is one that is even a transitive dependency of jboss-seam. That one doesn't work either. I would like to know which EL library to use.


          Any help is appreciated.


          Thanks.