3 Replies Latest reply on Jan 19, 2011 3:10 AM by pouria kazemi

    debug mode web app (debug="false")

    Calebe Varga Newbie

      Hi


      I have a simple Seam 2.2 web app POJO project.
      (war POJO not EJB3)


      When i submit any form in production environment, i am receiving a


      Target Unreachable,
      identifier 'blablablaForm' resolved to null


      I've discovered when i switch the compontents.xml to
      debug="false"
      i receive the error.


      I am using JBoss Seam 2.2.1.CR3 JBoss 6.Final


      This error not happens when
      debug="true"


      Components:



      <core:init debug="false" jndi-pattern="@jndiPattern@"/>

         <core:manager concurrent-request-timeout="500"
                       conversation-timeout="120000"
                       conversation-id-parameter="cid"
                       parent-conversation-id-parameter="pid"/>



      Error:



      javax.enterprise.resource.webcontainer.jsf.application] javax.el.PropertyNotFoundException: /blablablaForm.xhtml
      @20,83 action="#{blablablaForm.blablablaForm}": Target Unreachable, identifier 'blablablaForm' resolved to null: javax.faces.el.EvaluationException: javax.el.PropertyNotFoundException: /blablablaForm.xhtml @20,83
      action="#{blablablaForm.blablablaForm}": Target Unreachable,identifier 'blablablaForm' resolved to null


      The same happens when i exclude jboss-seam-debug.jar


      I need to set this to production environment !


      Someone please Help

        • 1. Re: debug mode web app (debug="false")
          Fabrice ABELLI Newbie

          Hi,


          When you are using seam in debug mode some classes are stored under a special classloader to enable hot redeployement. When switching to production mode, you need to move them to the standard classloader otherwise the will not be found. Try to see if you have a dev directory under your WEB-INF directory and move everything you find inside to the WEB-INF/classes directory.


          Hope it will help.

          • 2. Re: debug mode web app (debug="false")
            Calebe Varga Newbie

            Gi Fabrice


            It worked !


            I've moved the package from src/hot to src/main.
            I've done this a long time ago, but i didn't remember...


            Thanks a lot

            • 3. Re: debug mode web app (debug="false")
              pouria kazemi Newbie
              hi experts today i encountered another problem with selectmanycheckbox ;the snippet code including

              <h:selectManyCheckbox value="#{conversationBean.oneList}">
                  <s:selectItems value="#{conversationBean.anotherList}" var="something" label="#{something.name}">
              </s:selectItems>
              </h:selectManyCheckbox>


              and now i need to persist a list of selected(checked) from conversationBean.anotherList into conversationBean.oneList . i don,t know how to? please F1 me.(i mean i,m really get in trouble and really need your help)