3 Replies Latest reply on Oct 16, 2009 5:19 AM by martin mucha

    configuration of verstions tables does not work?

    martin mucha Newbie

      Hi,

      yesterday I've downloaded latest Hibernate and latest envers & start playing with it. I have here maven enterprise application which I deploy onto JBoss 4.2.3 AS.

      For testing envers I've created sample db with schema admin, which coincidelly contains Person as your quick examples. But when I run it I'm getting

      Caused by: org.apache.derby.client.am.SqlException: Table/View 'ADMIN.PERSON_AUD' does not exist.

      which I should not, since in my persistence.xml is this configuration

      <property name="org.jboss.envers.versionsTablePrefix" value="" />
       <property name="org.jboss.envers.versionsTableSuffix" value="_revize" />
       <property name="org.jboss.envers.revisionFieldName" value="revision_number" />
       <property name="org.jboss.envers.revisionTypeFieldName" value="revision_type" />


      alternatively I've tried anotate Person entity with
      @VersionsTable
      but this annotation is NOT PRESENT in what I've downloaded. I've browse through all my repo, but it's not there either.

      Sooo, where is it? Or why that easy-configuration does not work? Or what's wrong? And why there's _AUD suffix when default value should be _versions?

      any help will be very welcomed.