3 Replies Latest reply on Feb 6, 2012 8:21 AM by jemmerling

    error by: ant start.demo

    Kai Gebhardt Newbie

      Hello,

      I'm new here. I tried to use jBPM by the tutorial on http://docs.jboss.org/jbpm/v5.2/userguide/ch03.html#d0e402.

      I can install it by tipping 'ant install.demo'.

      But by tipping 'ant start.demo' an error occured. I don't know why. Can someone help me?

      The error message is:

       

      C:\jBPM\jbpm-installer>ant start.demo

      Buildfile: C:\jBPM\jbpm-installer\build.xml

      download.h2.check:

           [echo] Checking h2 download ...

      download.h2:

      start.h2:

      start.jboss:

      check.jboss.version:

      start.jboss5:

      check.jboss.version:

      start.jboss7:

      start.eclipse:

      start.human.task:

          [javac] C:\jBPM\jbpm-installer\build.xml:664: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds

          [javac] Compiling 1 source file to C:\jBPM\jbpm-installer\task-service\target

          [javac] error: error reading C:\ant\apache-ant-1.8.2\lib\jai-core-1.1.3.jar; error in opening zip file

          [javac] 1 error

      BUILD FAILED

      C:\jBPM\jbpm-installer\build.xml:664: Compile failed; see the compiler error out

      put for details.

       

      I think my JAVA_HOME variable is right, because 'ant install.demo' was successful. The file jai-core-1.1.3.jar exists in C:\ant\apache-ant-1.8.2\lib.

      So I realy helpless. I hope someone can help me.

       

      Big thanks!

       

      PS: I use a win7 64 bit system. I have custimizing the build.xml file by edit:

      114  <condition property="download.type" value="win32-x86_64">
      115    <and>
      116                <os family="windows" />
      117                <or>
      118                        <os arch="x86_64" />
      119                        <os arch="amd64" />
      120                </or>
      121        </and>
      122  </condition>

       

      That works for the installation of the demo. Only by use the start.demo script, the error occurs.

      Perhaps my ant is not right installed? I have used this tutorial:

      http://ant.apache.org/manual/index.html

      The steps 1-4 were successfull. By step 5 in error occured. I didn't try to fix it, because step 5-6 are optional. Can this be the reason?

       

      cu Kai

        • 1. Re: error by: ant start.demo
          jemmerling Newbie

          First, I have a 64-bit Windows 7 system and I saw no need to edit build.xml.

           

          Do you have ANT_HOME defined? On your system it should be C:\ant\apache-ant-1.8.2.

           

          Also I have %ANT_HOME%\bin on my PATH.

           

          Installing ANT should not require more that exploding the ZIP into the desired location and updating ANT_HOME and PATH. Not sure what steps you followed in the ant manual.

           

          The other puzzling thing is, in %ANT_HOME%\lib I don't see any jar named jai-core-1.1.3.jar and yet ant runs fine. Perhaps you should reinstall ant.

           

          C:\Users\jemmerling>dir  %ANT_HOME%\lib
          Volume in drive C is Windows7_OS
          Volume Serial Number is 52AD-6FD0

          Directory of C:\tools\apache-ant-1.8.2\lib

          12/15/2011  11:04 AM    <DIR>          .
          12/15/2011  11:04 AM    <DIR>          ..
          12/15/2011  11:04 AM             5,748 ant-antlr.jar
          12/15/2011  11:04 AM             3,178 ant-antlr.pom
          12/15/2011  11:04 AM             8,746 ant-apache-bcel.jar
          12/15/2011  11:04 AM             2,911 ant-apache-bcel.pom
          12/15/2011  11:04 AM             3,931 ant-apache-bsf.jar
          12/15/2011  11:04 AM             3,132 ant-apache-bsf.pom
          12/15/2011  11:04 AM             3,059 ant-apache-log4j.jar
          12/15/2011  11:04 AM             2,836 ant-apache-log4j.pom
          12/15/2011  11:04 AM            39,638 ant-apache-oro.jar
          12/15/2011  11:04 AM             3,055 ant-apache-oro.pom
          12/15/2011  11:04 AM             3,761 ant-apache-regexp.jar
          12/15/2011  11:04 AM             2,851 ant-apache-regexp.pom
          12/15/2011  11:04 AM             4,084 ant-apache-resolver.jar
          12/15/2011  11:04 AM             2,854 ant-apache-resolver.pom
          12/15/2011  11:04 AM             2,295 ant-apache-xalan2.jar
          12/15/2011  11:04 AM             3,806 ant-apache-xalan2.pom
          12/15/2011  11:04 AM             3,913 ant-commons-logging.jar
          12/15/2011  11:04 AM             2,950 ant-commons-logging.pom
          12/15/2011  11:04 AM            85,511 ant-commons-net.jar
          12/15/2011  11:04 AM             3,215 ant-commons-net.pom
          12/15/2011  11:04 AM            22,265 ant-jai.jar
          12/15/2011  11:04 AM             3,298 ant-jai.pom
          12/15/2011  11:04 AM             7,960 ant-javamail.jar
          12/15/2011  11:04 AM             3,210 ant-javamail.pom
          12/15/2011  11:04 AM             8,222 ant-jdepend.jar
          12/15/2011  11:04 AM             3,005 ant-jdepend.pom
          12/15/2011  11:04 AM             6,739 ant-jmf.jar
          12/15/2011  11:04 AM             2,819 ant-jmf.pom
          12/15/2011  11:04 AM            40,175 ant-jsch.jar
          12/15/2011  11:04 AM             3,075 ant-jsch.pom
          12/15/2011  11:04 AM           102,220 ant-junit.jar
          12/15/2011  11:04 AM             4,069 ant-junit.pom
          12/15/2011  11:04 AM             7,120 ant-junit4.jar
          12/15/2011  11:04 AM             2,913 ant-junit4.pom
          12/15/2011  11:04 AM            12,322 ant-launcher.jar
          12/15/2011  11:04 AM             2,419 ant-launcher.pom
          12/15/2011  11:04 AM            10,392 ant-netrexx.jar
          12/15/2011  11:04 AM             4,018 ant-netrexx.pom
          12/15/2011  11:04 AM             4,688 ant-parent.pom
          12/15/2011  11:04 AM             7,555 ant-swing.jar
          12/15/2011  11:04 AM             2,744 ant-swing.pom
          12/15/2011  11:04 AM            15,201 ant-testutil.jar
          12/15/2011  11:04 AM             2,985 ant-testutil.pom
          12/15/2011  11:04 AM         1,933,743 ant.jar
          12/15/2011  11:04 AM             9,876 ant.pom
          12/15/2011  11:04 AM             2,525 libraries.properties
          12/15/2011  11:04 AM               154 README
                        47 File(s)      2,417,186 bytes
                         2 Dir(s)  34,895,020,032 bytes free

          • 2. Re: error by: ant start.demo
            Kai Gebhardt Newbie

            Hey, thank you for answering!

            Reinstall ant solved the problem.

             

            "First, I have a 64-bit Windows 7 system and I saw no need to edit build.xml."

            I use a jdk 64 bit version. I think you use a 32 bit version. With 64 bit the modify was neccessary.

             

            Thanks for help,

            Kai

            • 3. Re: error by: ant start.demo
              jemmerling Newbie

              Hmm, this is what I believe to be my normal Java environment:

               

              Microsoft Windows [Version 6.1.7601]
              Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

              C:\Users\jemmerling>java -version
              java version "1.6.0_26"
              Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
              Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

              C:\Users\jemmerling>echo %JAVA_HOME%
              C:\glassfish3\jdk

              C:\Users\jemmerling>%JAVA_HOME%\bin\java -version
              java version "1.6.0_26"
              Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
              Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

              C:\Users\jemmerling>

               

              However looking at Eclipse, I can see that when Eclipse installed, it apparently found a 32-bit version of Java under C:\Program Files (x86)\Java and was able to use that. So the installation went forward with an unmodified build.xml.