2 Replies Latest reply on Feb 3, 2012 6:46 PM by 24565435

    EJB2 dependencies supported in JBoss AS 5.1?

    24565435 Newbie

      Dependencies can be demanded on a particular EJB3 service in JBoss AS 5.1. Please advise if this is also supported for EJB2 services in JBoss AS 5.1.

       

      JBoss AS 4.2.3 appears to support this, in that we could declare a dependency in the jboss.xml such as:

       

      <depends>jboss.j2ee:jndiName=Dependent,service=EJB</depends>

       

      However I now notice that, when I depend this in JBoss 5.1, I get a deployment time error, which indicates I cannot use this dependency.

       

      I have attached the log from JBoss 4.2.3 and JBoss 5.1 for comparison. Logs and an example to reproduce are included in the attached zip.

       

      Is this a bug? If so, what is the suggested workaround?