9 Replies Latest reply on Feb 10, 2012 6:08 AM by Tomaz Cerar

    JVM fatal error when deploying to remote JBossAS 7

    andeisen Newbie

      Hi,

       

      I try to deploy an EAR-application, but the server JVM breaks down.

      My Setup:

      JBoss 7.0.2 Arc started on a virtual machine on some other host.

      Eclipse Indigo and JBossTools 3.3.0 with ear-Projekt on my machine.

       

      I've added the JBoss7 as a server in Eclipse. If the server is run locally, Eclipse can deploy the ear project without any problems.

      If I export the EAR to file system and copy the file to a remote JBoss server, the deployment also finishes without any problems.

       

      If I deploy deploy the ear remotely (via SSH-setting), then the deployment process starts at the server, and the message

      INFO  [org.jboss.as.server.controller] Deployed "myApp.ear"
      
      

       

      appears. But immediately after that, the whole server jvm crashes:

       

      INFO  [org.jboss.as.server.controller] Deployed "myApp.ear"
      #
      # A fatal error has been detected by the Java Runtime Environment:
      #
      #  SIGSEGV (0xb) at pc=0x00007f9f32e3c680, pid=23175, tid=140320836618000
      #
      # JRE version: 6.0_18-b03
      # Java VM: Java HotSpot(TM) 64-Bit Server VM (16.0-b10 mixed mode linux-amd64 )
      # Problematic frame:
      # V  [libjvm.so+0x5be680]
      #
      # An error report file with more information is saved as:
      # /.../jboss-as-7.0.2.Final/bin/hs_err_pid23175.log
      #
      # If you would like to submit a bug report, please visit:
      #   http://java.sun.com/webapps/bugreport/crash.jsp
      #
      ./standalone.sh: line 140: 23175 Aborted                 "/usr/java/jdk1.6.0_18/bin/java" -server -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n "-Dorg.jboss.boot.log.file=/.../jboss-as-7.0.2.Final/standalone/log/boot.log" "-Dlogging.configuration=file:/.../jboss-as-7.0.2.Final/standalone/configuration/logging.properties" -jar "/.../jboss-as-7.0.2.Final/jboss-modules.jar" -mp "/.../jboss-as-7.0.2.Final/modules" -logmodule org.jboss.logmanager -jaxpmodule javax.xml.jaxp-provider org.jboss.as.standalone -Djboss.home.dir="/.../jboss-as-7.0.2.Final"
      

       

      If I look at the deployment directory at the remote host, the myApp.ear.deployed marker is also set.

      I am looking for any hints how I can fix this thanks

        • 1. Re: JVM fatal error when deploying to remote JBossAS 7
          Wolf-Dieter Fink Master

          I would recommend to use the latest JVM first and, if possible the latest 7.1 version.

          • 2. Re: JVM fatal error when deploying to remote JBossAS 7
            Ondrej Zizka Master

            Besides upgrading JDK to latest,

            I'd suggest following the advice from the error message:

             

            # If you would like to submit a bug report, please visit:
            #   http://java.sun.com/webapps/bugreport/crash.jsp

            • 3. Re: JVM fatal error when deploying to remote JBossAS 7
              andeisen Newbie

              Hi, thanks so far.

              Unfortunately I am not the server admin, so the java update will take some time as the development is not very urgent so far.

               

              But I found out some other facts about the error. I tried to avoid the JBoss Tools automatic publishing and created some ant-tasks. But with that approach

              (compiling the ejbModules, pack into jar, pack into ear, transfer via scp-task to remote deploy directory) the JVM also crashes.

               

              I changed some other things in the source code - related to message driven beans, because ant complained about an illegal state exception at mdb-property declaration.

              Now - and that drives me mad - I cant deploy the ear-File to the remote system at all! The same ear-File, that I can deploy without any problems on my local JBoss 7.0.2, is crashing

              the server JVM while deploying on the remote JBoss 7.0.2!

               

              Another strange issue:

              If I just rename the ear-file (lets assume myApp.ear) to a different name (NEWmyApp.ear), without syncing the changes with application.xml (that means, the application.xml <display name> is still myApp.ear),

              the local JBoss is able to deploy the ear-File, while the remote JBoss stops deployment with error

               

              ERROR [org.jboss.msc.service.fail] MSC00001: Failed to start service jboss.deployment.unit."NEWmyApp.ear".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."NEWmyApp.ear".STRUCTURE: Failed to process phase STRUCTURE of deployment "NEWmyApp.ear"

               

              if I change the display-name attribute to the ear-file name (NEWmyApp.ear) - guess what - the JVM crashes again.

               

              I try to update the server as soon as possible and hope I won't have that problems with a new JRE version

              • 4. Re: JVM fatal error when deploying to remote JBossAS 7
                Tomaz Cerar Master

                hi,

                 

                can you post your crash log (e.g. hs_err_pid23175.log) so maybe we can identify problem...

                 

                cheers,

                tomaz

                • 5. Re: JVM fatal error when deploying to remote JBossAS 7
                  andeisen Newbie

                  Hi,

                   

                  I attached the jvm crash log.

                  I just reproduced the crash: I exported myeap-Project from eclipse to a local folder on my hard disk and deleted all tmp/data stuff on both JBoss installations.

                  Then I copied that file to my local JBoss deployment folder - no problems with deployment and application is working.

                  After that, I copied the same ear-File to my remote JBoss server. And there the deployment seems to be also successful (printed on screen: Deployed myApp.ear).

                  But immediately after that, the server jvm crashes - see appended log file.

                   

                  Thanks in advance!

                   

                  //edit:

                  I edited the hs_err log ifle and replaced some company specific information as well as the .ear-Name.

                  • 6. Re: JVM fatal error when deploying to remote JBossAS 7
                    Tomaz Cerar Master

                    hi,

                     

                    it looks like you just ran out of permgen space. open standalone.conf (inside bin folder) and find line that has -Xmx and others and set permgen to something bigger.

                    -XX:MaxPermSize=256m would be good start.

                     

                    cheers,

                    tomaz

                    1 of 1 people found this helpful
                    • 7. Re: JVM fatal error when deploying to remote JBossAS 7
                      andeisen Newbie

                      Hi,

                       

                      thanks for your hint. Finally I could solve the problem. But it was not the memory settings in standalone.conf (crash occured even with 512mb as memory settings, while local jboss could deploy with only 64mb).

                      It was the debugger setting! The line

                       

                      JAVA_OPTS="$JAVA_OPTS -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n"

                       

                      was enabled. If I remove that line, the remote host is deploying without problems - and if I turn remote debugging on again, it crashes to deploy the same ear.

                      I don't now why this is happening - but as I don't really need remote debugging at this moment, I is ok for me. Thx.

                      • 8. Re: JVM fatal error when deploying to remote JBossAS 7
                        Wolf-Dieter Fink Master

                        sounds strange!

                        Do you have another JVM with remote debugging enabled on this box?

                         

                        I think this should be reported  http://java.sun.com/webapps/bugreport/crash.jsp because the JVM should show a message that the port is in use (what normally happen) and not crash

                        • 9. Re: JVM fatal error when deploying to remote JBossAS 7
                          Tomaz Cerar Master

                          It is strange but more than possible, also it is possible that bug was allready fixed as jdk used is quite old (update 18).

                          so if possible try with latest update (30 atm) and if it still does not work, please fill the crash report.

                           

                           

                          cheers,

                          tomaž