3 Replies Latest reply on Feb 10, 2012 5:26 AM by Wolf-Dieter Fink

    Jboss auto deploy plugin cannot connect to localhost:8080

    ~= ziggy =~ Newbie

      I configured the plugin in maven as shown below

       

      [code]

          <plugin>

                          <groupId>org.jboss.as.plugins</groupId>

                          <artifactId>jboss-as-maven-plugin</artifactId>

                          <version>7.0.2.Final</version>

                          <configuration>

                              <hostname>localhost</hostname>

                              <port>8080</port>

                              <filename>target/TestApp.war</filename>

                          </configuration>

                          <executions>

                              <execution>

                                  <phase>package</phase>

                                  <goals>

                                      <goal>deploy</goal>

                                  </goals>

                              </execution>

                          </executions>

          </plugin>

      [/code]

       

      I then trigger it using maven using

       

      [code]

          mvn -U clean install package

      [/code]

       

      It does build and everything works fine but fails when it starts the auto deployment.

       

      [code]

          INFO]

          INFO] --- jboss-as-maven-plugin:7.0.2.Final:deploy (default) @ TestApp ---

          INFO] Executing goal deploy on server localhost (127.0.0.1) port 8080.

          9-Feb-2012 16:18:46 org.jboss.remoting3.EndpointImpl <clinit>

          NFO: JBoss Remoting version 3.2.0.Beta2

          9-Feb-2012 16:18:46 org.xnio.Xnio <clinit>

          NFO: XNIO Version 3.0.0.Beta2

          9-Feb-2012 16:18:46 org.xnio.nio.NioXnio <clinit>

          NFO: XNIO NIO Implementation Version 3.0.0.Beta2

          INFO] ------------------------------------------------------------------------

          INFO] BUILD FAILURE

          INFO] ------------------------------------------------------------------------

          INFO] Total time: 58.768s

          INFO] Finished at: Thu Feb 09 16:18:52 GMT 2012

          INFO] Final Memory: 7M/18M

          INFO] ------------------------------------------------------------------------

          ERROR] Failed to execute goal org.jboss.as.plugins:jboss-as-maven-plugin:7.0.2.Final:deploy (default) on project TestApp: Could not execute goal deploy on TestApp.war. Reason: Could not connect to remote://localhost:8080 in 5000ms. Make sure the server is running and/or consider setting a longer timeout by setting -Dorg.jboss.as.client.connect.timeout=<timeout in ms>. -> [Help 1]

          ERROR]

          ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

          ERROR] Re-run Maven using the -X switch to enable full debug logging.

          ERROR]

      [/code]

       

      The error seems to suggest that it could not connect to the application server on localhost:8080. It is running and i can access it. Any ideas?

       

      Jboss version is 7.0.2

      Maven version is 3.0.4