2 Replies Latest reply on Feb 13, 2012 8:59 PM by yanny wang

    HornetQ VIRT keep on increasing to more than 9G (for both HornetQ 2.2.5 & 2.2.8)

    yanny wang Newbie

      I've seen this situation for both HornetQ 2.2.5 and 2.2.8.

       

      When the server is up and has messages sent to and consumed from, the VIRT (seen in TOP on linux) will keep on increase to more than 9G and it's still on-going.

       

      the RES only increased from 3.3g to 3.8G while the VIRT increased from 4G to 9G.

       

      any idea why this happens and how to reslove this issue?

       

      The HornetQ we use is standalone non-cluster version.

        • 2. Re: HornetQ VIRT keep on increasing to more than 9G (for both HornetQ 2.2.5 & 2.2.8)
          yanny wang Newbie

          yes. I'm usig paging and netty nio.

           

          Here is my configuration:

           

          <configuration xmlns="urn:hornetq"
                         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                         xsi:schemaLocation="urn:hornetq /schema/hornetq-configuration.xsd">

              <paging-directory>${data.dir:../data}/paging</paging-directory>

              <bindings-directory>${data.dir:../data}/bindings</bindings-directory>

              <journal-directory>${data.dir:../data}/journal</journal-directory>

              <journal-min-files>100</journal-min-files>

              <large-messages-directory>${data.dir:../data}/large-messages</large-messages-directory>
             
              <security-enabled>false</security-enabled>
          <journal-sync-non-transactional>false</journal-sync-non-transactional>

              <connectors>
                  <!--connector name="netty">
                     <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory</factory-class>
                     <param key="host"  value="${hornetq.remoting.netty.host:localhost}"/>
                     <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
                  </connector-->

                  <!--connector name="netty-throughput">
                      <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory</factory-class>
                      <param key="host" value="${hornetq.remoting.netty.host:localhost}"/>
                      <param key="port" value="${hornetq.remoting.netty.batch.port:5455}"/>
                      <param key="batch-delay" value="50"/>
                      <param key="direct-deliver" value="true"/>
                      <param key="use-nio" value="false"/>
                      <param key="tcp-no-delay" value="true"/>
                      <param key="tcp-send-buffer-size" value="1048576"/>
                      <param key="tcp-receive-buffer-size" value="1048576"/>
                  </connector-->
              </connectors>

              <acceptors>
                  <!--acceptor name="netty">
                     <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                     <param key="host"  value="${hornetq.remoting.netty.host:localhost}"/>
                     <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
                  </acceptor-->

                  <acceptor name="netty-throughput">
                      <factory-class>org.hornetq.core.remoting.impl.netty.NettyAcceptorFactory</factory-class>
                      <param key="host" value="${hornetq.remoting.netty.host:localhost}"/>
                      <param key="port" value="${hornetq.remoting.netty.batch.port:5455}"/>
                      <!--param key="batch-delay" value="50"/>
                      <param key="direct-deliver" value="true"/>
                      <param key="use-nio" value="false"/>
                      <param key="tcp-no-delay" value="true"/>
                      <param key="tcp-send-buffer-size" value="1048576"/>
                      <param key="tcp-receive-buffer-size" value="1048576"/-->
                  </acceptor>
              </acceptors>

              <!--
              <security-settings>
                 <security-setting match="#">
                    <permission type="createNonDurableQueue" roles="guest"/>
                    <permission type="deleteNonDurableQueue" roles="guest"/>
                    <permission type="consume" roles="guest"/>
                    <permission type="send" roles="guest"/>
                 </security-setting>
              </security-settings>
              -->

              <queues>
                  <queue name="DLQ">
                      <address>DLQ</address>
                      <durable>true</durable>
                  </queue>
                  <queue name="ExpiryQueue">
                      <address>ExpiryQueue</address>
                      <durable>true</durable>
                  </queue>
              </queues>

              <address-settings>
                  <!--default for catch all-->
                  <address-setting match="#">
                      <dead-letter-address>DLQ</dead-letter-address>
                      <expiry-address>ExpiryQueue</expiry-address>
                      <max-delivery-attempts>7</max-delivery-attempts>
                      <redelivery-delay>1000</redelivery-delay>
                      <max-size-bytes>10485761</max-size-bytes>
                      <page-size-bytes>10485760</page-size-bytes>
                      <message-counter-history-day-limit>10</message-counter-history-day-limit>
                      <address-full-policy>PAGE</address-full-policy>
                  </address-setting>
              </address-settings>

          </configuration>

           

          Thanks.