8 Replies Latest reply on Feb 12, 2013 5:09 AM by naviator

    JBoss AS7 did not start within 5 minutes

    Gunjan Bohra Newbie

      Hi 

        After Installation ,I run ant start.demo command

      and found following error on screen.

      "JBoss AS7 did not start within 5 minutes"

      I checked following

      1) I Checked no process is bound on port 80

      2) Run individual bat file (jbpm-5.2.0.Final-installer-full\jbpm-installer\jboss-as-7.0.2.Final\bin\standalone) did not show any error.

      3) No individual log folder is being created on following locatin :D:\NSF-E-Cap\jbpm-5.2.0.Final-installer-full\jbpm-installer\jboss-as-7.0.2.Final\standalone\log

       

      would you please help me to find out reason not to start JBoss AS7 services.

       

      With Thanks

        • 1. Re: JBoss AS7 did not start within 5 minutes
          Kumar Bijyendra Newbie

          Check if your JAVA_HOME is set properly(should be pointing to your installed JDK on your system) . Try echoing JAVA_HOME value while executing standalone.bat.

          • 2. Re: JBoss AS7 did not start within 5 minutes
            Hardik Dave Newbie

            Check if your port 8080 is free or not.

            • 3. Re: JBoss AS7 did not start within 5 minutes
              Sebastien Arbogast Newbie

              My port 8080 is free and JAVA_HOME is correctly set up (/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home) and yet I have the exact same error.

              • 4. Re: JBoss AS7 did not start within 5 minutes
                Mauricio Salatino Master

                This sounds as a generic AS7 Question. did you try running a fresh install of the AS alone? with none application deployed in it?

                Cheers

                • 5. Re: JBoss AS7 did not start within 5 minutes
                  le_roy Newbie

                  I'm dragging this thread up again because I'm also getting the same error and despite thorough searching I haven't found a valid answer for this problem.

                   

                  $ netstat -an | grep LISTEN | grep -v LISTENING
                  tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      -

                  tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      -

                  tcp        0      0 127.0.0.1:6010              0.0.0.0:*                   LISTEN      -


                  $ java -version
                  java version "1.6.0_30"

                  Java(TM) SE Runtime Environment (build 1.6.0_30-b12)

                  Java HotSpot(TM) 64-Bit Server VM (build 20.5-b03, mixed mode)


                  $ echo $JAVA_HOME

                  /u01/app/jdk1.6.0_30/

                   

                   

                  Starting AS7 on it's own does not throw any errors.  I'm trying to start the demo using:

                  ant -f build.xml start.demo.noeclipse

                   

                  Which throws the following error when trying to login to the console as admin:

                   

                  URL:'http://myserver::8989/gwt-console-server/rs/tasks/admin'
                  Action: 'org.jboss.bpm.console.client.task.LoadTasksAction'

                  Exception: 'class com.google.gwt.http.client.RequestException'

                   

                  HTTP 500:


                  org.jboss.resteasy.spi.UnhandledException: java.lang.IllegalArgumentException: Could not connect task client

                  org.jboss.resteasy.core.SynchronousDispatcher.unwrapException(SynchronousDispatcher.java:345)

                  org.jboss.resteasy.core.SynchronousDispatcher.handleApplicationException(SynchronousDispatcher.java:321)

                  org.jboss.resteasy.core.SynchronousDispatcher.handleException(SynchronousDispatcher.java:214)

                  org.jboss.resteasy.core.SynchronousDispatcher.handleInvokerException(SynchronousDispatcher.java:190)

                  org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:534)

                  org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:496)

                  org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:119)


                   

                  I'm assuming the task client is failing because that follows AS7 in the demo startup script.

                   

                   

                  Buildfile: /u01/app/jbpm/build.xml

                   

                  download.h2.check:

                       [echo] Checking h2 download ...

                   

                  download.h2:

                   

                  start.h2:

                   

                  start.jboss:

                   

                  check.jboss.version:

                   

                  start.jboss5:

                   

                  check.jboss.version:

                   

                  start.jboss7:

                   

                  BUILD FAILED

                  /u01/app/jbpm/build.xml:531: The following error occurred while executing this line:

                  /u01/app/jbpm/build.xml:555: JBoss AS7 did not start within 5 minutes

                   

                  Total time: 5 minutes 0 seconds

                   

                   

                  Any help is appreciated.

                  le_roy

                  • 6. Re: JBoss AS7 did not start within 5 minutes
                    le_roy Newbie

                    Hopefully this helps others.

                     

                    1. Before installing (ant install.demo.noeclipse), modify $JBPM_HOME/build.xml file with the ports you'd like JBoss to run on.

                    2. Ensure all environment variables are set properly and directories exist before trying to start.

                    3. Reinstall jbpm with ant clean.demo; ant install.demo.noeclipse.  NOTE: this removes the entire jboss sub-directory, so any modifications you've made will be removed.

                    • 7. Re: JBoss AS7 did not start within 5 minutes
                      naviator Newbie

                      Hey,

                       

                      in case you didn't solve your problem yet - can you post result of verbose ant? Try:

                      ant -v start.demo

                       

                      I had a similar problem, in my case ant build was stuck at "Checking for listener at localhost:8080", repeated several times. Then I realized: I have JAVA_HOME variable set to Java 1.7, so I switched to 1.6 and it worked! Detailed steps for Mac OS X: have your JAVA_HOME variable set to output of:

                      /usr/libexec/java_home -v1.6

                       

                      In my case, that was:

                      /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

                       

                      and finally: ant start.demo

                       

                      Hope some of it helps.

                      • 8. Re: JBoss AS7 did not start within 5 minutes
                        naviator Newbie

                        Hello Sebastien,

                         

                        try setting your JAVA_HOME to:

                        /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

                         

                        I know the symlinked /System/Library/Frameworks/... should work but I tried both versions and only one of them did. Which output does:

                        /usr/libexec/java_home -v1.6

                         

                        give you?

                         

                        Hopefully helps.

                         

                        EDIT:

                         

                        might be related to issue https://issues.jboss.org/browse/JBAS-6981