5 Replies Latest reply on Feb 16, 2012 9:18 AM by markus78

    No XA Datasources or statistics under runtime tab

    markus78 Newbie

      Hello,

       

      I have defined 3 XA Datasources and they all show up under the profile tab in the admin console , but when I want to inspect the runtime usage this is what I get

       

      test.jpg

       

      The list is empty but still states 1-3 of 3 in the bottom of the list.

      There is no statistics saved or presented back either.

       

      I used Chrome and Explorer and the problem existed in both versions, Is there some setting I have to set? the datasources work fine in the application.

      I'm using the 7.1-Final version.

       

      BR

      /Markus

        • 1. Re: No XA Datasources or statistics under runtime tab
          Heiko Braun Master

          Can you take a look at "View>Developer>JavaScript Console" and post the log contents here? The server logs are worth investigating as well.

          • 2. Re: No XA Datasources or statistics under runtime tab
            markus78 Newbie

            The following is dumped in the javascript consol

             

             

            2012-02-16 14:44:42,126 [FATAL] Uncaught Exception:
            com.google.gwt.event.shared.UmbrellaException: One or more exceptions caught, see full set in UmbrellaException#getCauses
                at Unknown.hg(Unknown Source)
                at Unknown.li(Unknown Source)
                at Unknown.wx(Unknown Source)
                at Unknown.yx(Unknown Source)
                at Unknown.Qw(Unknown Source)
                at Unknown.xCc(Unknown Source)
                at Unknown.PCc(Unknown Source)
            Caused by: java.lang.RuntimeException: DataSource selection is null!
                at Unknown.hg(Unknown Source)
                at Unknown.ki(Unknown Source)
                at Unknown.Bde(Unknown Source)
                at Unknown.Dde(Unknown Source)
                at Unknown.Wee(Unknown Source)
                at Unknown.wCc(Unknown Source)
                at Unknown.$w(Unknown Source)
            
            

             

            And

             

            2012-02-16 14:44:42,140 [FATAL] Uncaught Exception:
            java.lang.IllegalStateException: The Cell Widget is attempting to render itself within the render loop. This usually happens when your render code modifies the state of the Cell Widget then accesses data or elements within the Widget.
                at Unknown.hg(Unknown Source)
                at Unknown.eMc(Unknown Source)
                at Unknown.Xgc(Unknown Source)
                at Unknown.rhc(Unknown Source)
                at Unknown.Fp(Unknown Source)
                at Unknown.tp(Unknown Source)
                at Unknown.np(Unknown Source)
            
            

             

            I dont get anything in the server logs though.

            /Markus

            • 3. Re: No XA Datasources or statistics under runtime tab
              Heiko Braun Master

              Would it be possible that you provide me with the actual server xml configuration? For 7.1 that would be standalone-full.xml I think. You can attach it here:

               

              https://issues.jboss.org/browse/AS7-3795

              • 4. Re: No XA Datasources or statistics under runtime tab
                Heiko Braun Master

                Something simple you might try before we dig any further: clear chromes cache, reload and try again: "Chrome" > "Clear browsing data". If you happen to be running recent development, or previously released AS7 version then this might cause some problems. Alternatively try another browser. This would already nail it down.

                • 5. Re: No XA Datasources or statistics under runtime tab
                  markus78 Newbie

                  That did not work for me (clearing the chache), I have attached a standalone.xml to the Jira ( I removed 2 datasources and login credentials though... )