1 Reply Latest reply on Mar 13, 2012 2:40 PM by Alessio Soldano

    Install jbossws-cxf 4.0.0GA in JBoss AS 6.0

    hmr_mueller Newbie

      We need the SAML-Token-Profile for WS Security to be able to authenticate the web services. Since we are using JBoss AS 6.0, I'd like to install jbossws-cxf 4.0.0 GA in this version of JBoss AS.

      Since jbossws-cxf 4.0.0 GA does not support the installation in JBoss AS 6.0, I used jbossws-cxf 4.0.0 CR1 and copied the libs of the GA version to the lib directory.

       

      According to  https://community.jboss.org/message/639889#639889 I installed jbossws-native-4.0.0GA first with the method described before (using the CR1 installer)

       

      On server startup I get the exception:

       

      at org.jboss.bootstrap.impl.base.server.AbstractServer.startBootstraps(AbstractServer.java:827) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]
      at org.jboss.bootstrap.impl.base.server.AbstractServer$StartServerTask.run(AbstractServer.java:417) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]
      at java.lang.Thread.run(Thread.java:619) [:1.6.0_21]

      Caused by: java.lang.IllegalArgumentException: Exception loading class for ScopeKey addition.

      at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addComponent(BeanMetaDataFactoryVisitor.java:58) [:2.2.0.GA]
      at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addComponent(BeanMetaDataFactoryVisitor.java:35) [:2.2.0.GA]
      at org.jboss.deployers.spi.deployer.helpers.AbstractDeploymentVisitor.deploy(AbstractDeploymentVisitor.java:73) [:2.2.0.GA]
      ... 48 more

      Caused by: java.lang.ClassNotFoundException: org.jboss.wsf.stack.cxf.config.CXFInitializer from BaseClassLoader@538cc2{vfs:///<jboss-home>/server/test/deployers/jbossws.deployer}

      at org.jboss.classloader.spi.base.BaseClassLoader.loadClass(BaseClassLoader.java:480) [jboss-classloader.jar:2.2.0.GA]
      at java.lang.ClassLoader.loadClass(ClassLoader.java:248) [:1.6.0_21]
      at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addComponent(BeanMetaDataFactoryVisitor.java:54) [:2.2.0.GA]
      ... 50 more

       

      Is there a way to install jbossws-cxf 4.0.0GA in JBoss AS 6.0?

       

      Thanks.