3 Replies Latest reply on Feb 18, 2012 6:30 AM by Joseph Fouts

    Upgrade from 7.1.0.CR1b to 7.1.0.Final

    Joseph Fouts Novice

      I have a sample client/server app I created to test our connection to a db2 database using JBoss 7.

       

      I setup the db2 type 4 universal driver as a module.

      You can view how I set this up at this thread:  https://community.jboss.org/message/716557#716557

       

      Everything worked fine. 

       

      I then upgraded to Jboss 7.1.0.Final and I get 2 new errors when starting the server.

       

      WARNING: -logmodule is deprecated. Please use the system property 'java.util.logging.manager' or the 'java.util.logging.LogManager' service loader.

       

      And now my db2 driver is complaining about dependencies.

       

      11:27:00,338 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.db2jcc (missing) dependents: [service jboss.data-source.java:/admindatasource]

       

       

      I think I setup the JBoss 7.1.0.Final just as I did the CR1b.

       

      Does anyone have any ideas on what I might have missed that would now give me the WARNING message and the

      New missing/unsatisfied dependencies errors.

       

      Any help is greatly appreciated.

       

      Thanks

        • 1. Re: Upgrade from 7.1.0.CR1b to 7.1.0.Final
          Joseph Fouts Novice

          I found a typo in my standalone.xml where I was defining the:

          <driver-class> definition.

           

          db2 driver works fine now.

           

          Still not sure why I am now getting the Warning message about the logger.

           

          Any ideas?

           

          Thanks.

          • 2. Re: Upgrade from 7.1.0.CR1b to 7.1.0.Final
            jaikiran pai Master

            WARNING: -logmodule is deprecated. Please use the system property 'java.util.logging.manager' or the 'java.util.logging.LogManager' service loader.

            Where are you seeing that message? On the server side? How are you starting it? The recent version of JBoss Modules which is shipped in AS 7.1.0.Final no longer supports that -logmodule parameter, hence it prints out the message.

            • 3. Re: Upgrade from 7.1.0.CR1b to 7.1.0.Final
              Joseph Fouts Novice

              Hi and thanks for your help.

               

              The message was coming out as the first entry on the console when starting the server.

               

              When we first installed CR1b we kept getting warning messages about the logger.

               

              Someplace we found wout that we needed to add the following to our server startup scripts and in Eclipse:

               

                         -logmodule org.jboss.logmanager

               

              **Removed argument from server startup scripts and in Eclipse and the Warning message went away.

               

              Thanks for your help.