0 Replies Latest reply on Feb 22, 2012 11:14 AM by thomas3mt

    Problems deploying and starting webapp on JBoss AS 7.1.0.Final

    thomas3mt Newbie

      Hi,

       

      I have problems deploying a webapp on 7.1.0.Final. The application deploys without any problems on 7.1.0.CR1

       

      The app uses mysql + eclipselink. Those modules are installed and confirmed trough console / log loaded ok.

       

      When i add the application to the server it deploys ok. When i try to add the app to server group it just handgs (in the web console).

       

      From command-line console i can see that the dependencies are sorted out, the perisistence unit is found, and that it looks "fine".

       

      Last message i see is;

       

      [Server:server-one] 16:07:59,233 DEBUG [org.jboss.as.ejb3.deployment.processors.EjbClientContextSetupProcessor] (MSC service thread 1-4) Deployment unit deployment "****.war" doesn't have any explicit EJB client context configured. Falling back on the default service jboss.ejb3.ejbClientContext.default EJB client context service

      [Server:server-one] 16:07:59,235 DEBUG [org.jboss.as.ejb3.deployment.processors.EjbClientContextSetupProcessor] (MSC service thread 1-4) Registering EJB client context org.jboss.ejb.client.EJBClientContext@42b36022 for classloader ModuleClassLoader for Module "deployment.****.war:main" from Service Module Loader

      [Server:server-one] 16:07:59,312 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV named javax.servlet.jsp.jstl.tlv.PermittedTaglibsTLV

      [Server:server-one] 16:07:59,426 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: org.apache.catalina.servlets.DefaultServlet named org.apache.catalina.servlets.DefaultServlet

      [Server:server-one] 16:07:59,430 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: javax.faces.webapp.FacetTag named javax.faces.webapp.FacetTag

      [Server:server-one] 16:07:59,433 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: com.sun.faces.config.ConfigureListener named com.sun.faces.config.ConfigureListener

      [Server:server-one] 16:07:59,436 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: ***** named *****

      [Server:server-one] 16:07:59,437 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: javax.servlet.jsp.jstl.tlv.ScriptFreeTLV named javax.servlet.jsp.jstl.tlv.ScriptFreeTLV

      [Server:server-one] 16:07:59,440 DEBUG [org.jboss.as.ee] (MSC service thread 1-3) Configuring component class: org.apache.jasper.servlet.JspServlet named org.apache.jasper.servlet.JspServlet

       

      (**** is anonymized webapp package)

       

      When i press "ctrl-c" to break/quit the "./domain.sh" process it hangs for a very long time / i have to kill it forcefully.. It seems that something that is waiting / hanging. But im not sure..

       

      I really need some pinpoints on where to continue looking. Thanks.

       

      br

      Thomas