0 Replies Latest reply on Feb 29, 2012 5:47 AM by rajesh kakawat

    Parameter in birt report passed from jsp is not working

    rajesh kakawat Newbie

      I am using Eclipse Birt 3.7 which is working fine in Eclipse but when i deployed it on tomcat 6 it is not working.

       

      Normal report which are without parameter are working fine on tomcat but report are not working correctly when Parameter are passed from jsp.

      I have been using Jboss tool for birt and using hibernate3.6 for ORM and have use org.jboss.tools.birt.oda_1.2.0.v20110809.jar

      I am getting following error;

       

      AxisFault

       

      faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException

       

      faultSubcode:

       

      faultString: org.eclipse.birt.report.service.api.ReportServiceException: Error happened while running the report.

       

      faultActor:

       

      faultNode:

       

      faultDetail:

       

      {http://xml.apache.org/axis/}stackTrace:org.eclipse.birt.report.service.api.ReportServiceException: Error happened while running the report.

       

      at org.eclipse.birt.report.service.ReportEngineService.throwDummyException(ReportEngineService.java:1106)

      at org.eclipse.birt.report.service.ReportEngineService.runReport(ReportEngineService.java:1326)

       

      at org.eclipse.birt.report.service.BirtViewerReportService.runReport(BirtViewerReportService.java:158)

       

      at org.eclipse.birt.report.service.actionhandler.BirtRunReportActionHandler.__execute(BirtRunReportActionHandler.java:81)

       

      at org.eclipse.birt.report.service.actionhandler.AbstractBaseActionHandler.execute(AbstractBaseActionHandler.java:90)

       

      at org.eclipse.birt.report.presentation.aggregation.layout.EngineFragment.doService(EngineFragment.java:265)

       

      at org.eclipse.birt.report.presentation.aggregation.AbstractBaseFragment.service(AbstractBaseFragment.java:76)

       

      at org.eclipse.birt.report.servlet.BirtEngineServlet.__doGet(BirtEngineServlet.java:120)

      at org.eclipse.birt.report.servlet.BaseReportEngineServlet.doGet(BaseReportEngineServlet.java:185)

       

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)....

       

      Caused by: java.lang.NoSuchFieldError: STRING

       

      at org.jboss.tools.birt.oda.impl.Parameter.<clinit>(Parameter.java:26)

       

      at org.jboss.tools.birt.oda.impl.HibernateOdaQuery.setInt(HibernateOdaQuery.java:152)

       

      at org.eclipse.datatools.connectivity.oda.consumer.helper.OdaQuery.setInt(OdaQuery.java:533)

       

      at org.eclipse.birt.data.engine.odaconsumer.PreparedStatement.doSetInt(PreparedStatement.java:4213)

       

      at org.eclipse.birt.data.engine.odaconsumer.PreparedStatement.setInt(PreparedStatement.java:3847)....

       

      According to me Class Parameter present in package org.jboss.tools.birt.oda.impl use Hibernate.STRING which is deprecated, is causing problem.

      But when I change all Class hibernate deprecated variable to StandardBasicTypes.STRING respectively.

      It is working fine.

       

      Is it bug present in Jboss birt tool ????