3 Replies Latest reply on Mar 1, 2012 10:10 AM by Kirill Linnik

    buttons in rich:popupPanel

    Kirill Linnik Newbie

      Well, here I am with another weird issue.

       

      Given:

      <h:form id="formSearch">
                <rich:popupPanel id="resultList" modal="true" autosized="true"
                     domElementAttachment="form">
      
                     <rich:dataTable id="vehicleSearchResults"
                          rows="#{vehicleSearchDataModel.numberOfRows}" width="100%" border="0"
                          cellspacing="0" cellpadding="0" styleClass="datatable"
                          value="#{vehicleSearchDataModel}" var="foundVehicle"
                          onRowMouseOver="this.style.backgroundColor='#FFFFFF'"
                          onRowMouseOut="this.style.backgroundColor='#F8F8F8'">
      
                          <rich:column>
                               <f:facet name="header">
                               </f:facet>
                               <h:outputText value="#{foundVehicle}" />
                               <h:commandLink styleClass="detailsbtn"
                                    action="#{searchResultBean.actionMethod}">
                                    <f:param name="vehicleSearchId" value="1" />
                                    <span> <h:outputText value="#{msg.btn_select}" />
                                    </span>
                               </h:commandLink>
                          </rich:column>
      ...
      
      

       

      The problem is: sometimes searchResultBean.actionMethod method fired, sometimes - not. Log is clear, no exceptions at all. No JS errors too. Requests (in FireBug) are absolutule identical for both cases. For example, if search form is empty, then it's working. In cases where 1-4 results are displayed - only the first 1-2 rows are fired, the last 1-2 are not going into searchResultBean.actionMethod at all. Where can be the root of the issue and how to debug this stuff? Thanks in advance, Kirill