4 Replies Latest reply on Mar 2, 2012 1:01 PM by Jason Porter

    Seam 3.1 NPE in TransactionServletListener on Websphere 8

    tmanning Newbie

      I've been struggling trying to get SeamFaces 3.x working on Websphere 8.0.0.1.  I ran into two problems with SeamFaces 3.0 related to the OWB implementation included in WAS and I've received patches from IBM to fix the problem, but I was getting some more exceptions and decided to upgrade to SeamFaces 3.1.0.Final and see what I could see.

       

      It turns out everything breaks, and the stack trace suggests that the issue SEAMTRANSACTION-15 is the culprit - apparently in WAS (and also in Tomcat) you cannot @Inject into a ServletListener?

       

      {code}

      E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [Servlet Error]-[ServletNameNotFound]: java.lang.NullPointerException

                at org.jboss.seam.transaction.TransactionServletListener.requestInitialized(TransactionServletListener.java:106)

                at com.ibm.ws.webcontainer.webapp.WebApp.notifyServletRequestCreated(WebApp.java:1812)

                at com.ibm.wsspi.webcontainer.collaborator.CollaboratorHelper.preInvokeCollaborators(CollaboratorHelper.java:477)

      {code}

       

      Does anyone else have any experience with WAS/OWB and SeamFaces 3.1 (or even 3.0)?

       

      I ran across this post: https://community.jboss.org/thread/178664 which describes disabling seam-managed transactions completely (which would be nice) but I was unable to get it working.