4 Replies Latest reply on Mar 6, 2012 8:26 AM by gboro54

    EJB Remote Client Issues

    gboro54 Novice

      I have deployed a project strucutred as follows:

      • service.ear
        • service-ejb.jar
          • RemoteEJB.class

       

       

      I am trying to invoke this bean from another instance running on JBoss packaged as follows:

      • client.ear
        • META-INF
          • jboss-ejb-client.xml
        • client.jar
          • client classes

       

      When I try and invoke the bean I get the following excepction:

       

      {code}

      08:22:28,133 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.ejb3.dd-based-ejb-client-context."client.ear": org.jboss.msc.service.StartException in service jboss.ejb3.dd-based-ejb-client-context."client.ear": Failed to start service

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) [rt.jar:1.6.0_27]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.6.0_27]

                at java.lang.Thread.run(Unknown Source) [rt.jar:1.6.0_27]

      Caused by: java.lang.RuntimeException: Operation failed with status WAITING

                at org.jboss.ejb.client.remoting.IoFutureHelper.get(IoFutureHelper.java:93)

                at org.jboss.as.ejb3.remote.DescriptorBasedEJBClientContextService.createRemotingConnections(DescriptorBasedEJBClientContextService.java:124)

                at org.jboss.as.ejb3.remote.DescriptorBasedEJBClientContextService.start(DescriptorBasedEJBClientContextService.java:86)

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                ... 3 more

       

      {code}

       

      My jboss-ejb-client.xml

      {code:xml}

      <jboss-ejb-client xmlns="urn:jboss:ejb-client:1.0">

          <client-context>

              <ejb-receivers exclude-local-receiver="true">

                  <remoting-ejb-receiver outbound-connection-ref="common-ejb-connection"/>

              </ejb-receivers>

          </client-context>

      </jboss-ejb-client>

       

      {code}

       

      My service config(fragments)

      {code:xml}

              <subsystem xmlns="urn:jboss:domain:remoting:1.1">

                  <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>

                  <outbound-connections>

                      <remote-outbound-connection name="common-ejb-connection" outbound-socket-binding-ref="common-services-binding">

                          <properties>

                              <property name="SASL_POLICY_NOANONYMOUS" value="false"/>

                              <property name="SSL_ENABLED" value="false"/>

                          </properties>

                      </remote-outbound-connection>

                  </outbound-connections>

              </subsystem>

                ....

                ....

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

                ....

              <outbound-socket-binding name="common-services-binding">

                  <remote-destination host="<remote-ip>" port="4447"/>

              </outbound-socket-binding>

          </socket-binding-group>

       

       

      {code}

       

       

       

      Am I missing something in the configuration?