5 Replies Latest reply on Mar 16, 2012 8:24 AM by pchauviaux

    a4j:status not working after reRendering

    pchauviaux Newbie

      Hello,

      In our project, the a4j:status is working only the first time. The following times, it is not working anymore (except if we do a refresh). I have done a small test (based on the showcase's example) and I have seen that the problems came after a reRender has been done.

      We are using Richfaces 3.3.3 Final.

       

      Here is the sample code I used to reproduce the problem:

       

      <ui:composition xmlns="http://www.w3.org/1999/xhtml"

            xmlns:ui="http://java.sun.com/jsf/facelets"

            xmlns:h="http://java.sun.com/jsf/html"

            xmlns:f="http://java.sun.com/jsf/core"

            xmlns:a4j="http://richfaces.org/a4j"

            xmlns:rich="http://richfaces.org/rich">

                 

          <h:outputText value="Ajax  Status:"/>

       

       

          <a4j:status id="commonstatus"  startText="In progress..." stopText="Complete"/>

       

       

          <br />

          <rich:spacer height="5" />

          <h:form>

                <a4j:commandButton eventsQueue="foo" value="Ajax Request" reRender="testR"/>

                <br/>

                <br/>

                <a4j:outputPanel id="testR">

                          Test panel

               </a4j:outputPanel>

          </h:form>

         

      </ui:composition>

       

      Do you know a way to make the a4j:status work even after a reRender?

       

      Remark: the problem appears also if there is a rich:messages on the page, but it could be solved by adding: ajaxRendered="false".

       

      Thanks in advance.