4 Replies Latest reply on Sep 25, 2012 10:44 AM by Marco Lala

    Debugger Stopped Working

    Stephen Seltzer Newbie

      To start, my system is:

      Windows 7 (64bit)

      Eclipse Indigo (Build id: 20110916-0149)

      JBossASTools (Version: 2.3.0.v20111213-1423-H61-M5)

      JBoss AS 7.1

       

      I have had this configuration up and running for over a month. Suddenly starting yesterday I have been unable to start up my system in debug. I have made no significant changes to my system (save for the installation of TOAD but it was still working for a while after that was installed). It will start fine in run mode and it starts in < 10 seconds. When I start using the debugger, it takes > 1:30 and then fails in the end. The last couple of lines from server.log are:

       

      10:11:11,188 INFO  [org.jboss.web] (MSC service thread 1-2) JBAS018210: Registering web context: /speed2
      10:11:11,207 DEBUG [org.apache.jasper.servlet.JspServlet] (MSC service thread 1-3) JspServlet.destroy()
      10:11:11,214 DEBUG [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/speed2]] (MSC service thread 1-3) Stopping filters
      10:11:11,220 DEBUG [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/speed2]] (MSC service thread 1-3)  Stopping filter 'com.newpig.speed2.filters.NoCacheFilter'
      10:11:11,227 DEBUG [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/speed2]] (MSC service thread 1-3)  Stopping filter 'MyFacesExtensionsFilter'
      10:11:11,238 DEBUG [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/speed2]] (MSC service thread 1-3)  Stopping filter 'noCacheFilter'
      10:11:11,244 DEBUG [org.apache.catalina.session.ManagerBase] (MSC service thread 1-3) Unloading persisted sessions
      10:11:11,250 DEBUG [org.apache.catalina.core.StandardContext] (MSC service thread 1-3) Sending application stop events
      10:11:11,255 FINE  [javax.enterprise.resource.webcontainer.jsf.config] (MSC service thread 1-3) ConfigureListener.contextDestroyed(null)
      10:11:11,271 DEBUG [org.apache.catalina.core.StandardContext] (MSC service thread 1-3) Processing standard container shutdown
      10:11:11,277 DEBUG [org.apache.catalina.startup.ContextConfig] (MSC service thread 1-3) ContextConfig: Processing STOP
      10:11:11,291 DEBUG [org.apache.catalina.core.StandardContext] (MSC service thread 1-3) resetContext null
      10:11:11,296 DEBUG [org.apache.catalina.core.StandardContext] (MSC service thread 1-3) Stopping complete
      10:11:13,150 ERROR [org.jboss.as] (MSC service thread 1-7) JBAS015875: JBoss AS 7.1.0.Final "Thunder" started (with errors) in 93195ms - Started 407 of 481 services (1 services failed or missing dependencies, 72 services are passive or on-demand)
      10:11:16,251 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015877: Stopped deployment speed2.war in 34435ms
      

       

      I have attached a zip containing server.log files from starting with a plain run and starting in debug to show the success/failure. Also, I bumped my logging up to DEBUG to give a little more information.

       

      Any assistance getting my debugging back on line sure would be appreciated!

      Steve