3 Replies Latest reply: Mar 13, 2013 12:15 PM by Edmund Geesken RSS

POJO Cache failing on weblogic 11g managed servers

paramita banerjee Newbie



I have set up Pojo cache to work with weblogic server 11g.

I have annotated and instrumented the classes as mentioned in user guide.


The Pojo cache attach/find works well when I deploy the application on weblogic admin server.


But when I deploy the application on any managed servers in the same weblogic domain, I get the following exception:


at org.jboss.aop.Domain$1.run(Domain.java:124)

at org.jboss.aop.Domain$1.run(Domain.java:121)

at org.jboss.aop.Domain.getDomainName(Domain.java:119)

at com.hp.ws.business.session.WsSession$WsSessionAdvisor.initialise(WsSession$WsSessionAdvisor.java)

at com.hp.ws.business.session.WsSession$WsSessionAdvisor.(WsSession$WsSessionAdvisor.java)

at com.hp.ws.business.session.WsSession.(WsSession.java)


I am using jbosscache-pojo-3.0.0.GA and weblogic 11g


Any help is highly appreciated.

  • 1. Re: POJO Cache failing on weblogic 11g managed servers
    paramita banerjee Newbie

    Further to my above question, I checked into the weblogic managed server log file, and found the following detailed error:

    I downloaded the latest version of jboss-aop.jar and re-instrumented the classes,
    now I am getting another exception only on the managed weblogic server instances.
    I find no issues with the same application deployed on weblogic Admin Server running on the same domain.

    This is really confusing to me, can anyone please help.


    Caused By: java.lang.NullPointerException
    at org.jboss.aop.instrument.JoinPointGenerator.findAdvisedField(JoinPointGenerator.java:500)
    at org.jboss.aop.instrument.JoinPointGenerator.<init>(JoinPointGenerator.java:188)
    at org.jboss.aop.instrument.FieldJoinPointGenerator.<init>(FieldJoinPointGenerator.java:86)
    at org.jboss.aop.GeneratedClassAdvisor$ClassAdvisorStrategy.getJoinPointGenerator(GeneratedClassAdvisor.java:1332)
    at org.jboss.aop.GeneratedClassAdvisor.getJoinPointGenerator(GeneratedClassAdvisor.java:786)
    at org.jboss.aop.GeneratedClassAdvisor.fullWorkFinalizeFieldChain(GeneratedClassAdvisor.java:706)
    at org.jboss.aop.GeneratedClassAdvisor.finalizeFieldReadChain(GeneratedClassAdvisor.java:665)
    at org.jboss.aop.GeneratedClassAdvisor.finalizeChains(GeneratedClassAdvisor.java:581)
    at org.jboss.aop.ClassAdvisor.createInterceptorChains(ClassAdvisor.java:609)
    at org.jboss.aop.GeneratedClassAdvisor.access$201(GeneratedClassAdvisor.java:65)
    at org.jboss.aop.GeneratedClassAdvisor$ClassAdvisorStrategy.createInterceptorChains(GeneratedClassAdvisor.java:1306)
    at org.jboss.aop.GeneratedClassAdvisor.createInterceptorChains(GeneratedClassAdvisor.java:410)
    at org.jboss.aop.ClassAdvisor$1.run(ClassAdvisor.java:306)
    at org.jboss.aop.ClassAdvisor.attachClass(ClassAdvisor.java:276)
    at org.jboss.aop.AspectManager.initialiseClassAdvisor(AspectManager.java:748)
    at org.jboss.aop.GeneratedClassAdvisor$ClassAdvisorStrategy.initialise(GeneratedClassAdvisor.java:1294)
    at org.jboss.aop.GeneratedClassAdvisor.initialise(GeneratedClassAdvisor.java:146)
    at com.hp.ws.business.session.WsSession$WsSessionAdvisor.initialise(WsSession$WsSessionAdvisor.java)
    at com.hp.ws.business.session.WsSession$WsSessionAdvisor.<init>(WsSession$WsSessionAdvisor.java)
    at com.hp.ws.business.session.WsSession.<clinit>(WsSession.java)

  • 2. Re: POJO Cache failing on weblogic 11g managed servers
    Edmund Geesken Newbie



    has anyone solved this problem?

    I have the same error message at exactly the same line.

    I am using jboss-aop.2.1.8.GA.

    I am using the jboss-pojo-cache and reinstrumented all my classes using the new jboss-aop.

    There is no other aop package in my classpath and i have included all of the jars included in the distribution into my ear APP-INF/lib directory.


    I am trying to upgrade my application from WebLogic 10.3.0 to WebLogic 10.3.6.

    The application is productive for more than 3 years.


    My environment is WebLogic 10.3.6, JDK 1.6_29

    The Pojo-Cache ist the 3.0.0.GA, latest release.


    Has anyone a solution for this?




  • 3. Re: POJO Cache failing on weblogic 11g managed servers
    Edmund Geesken Newbie

    I have found the reason for this exception by myself.

    The Exception is fired because the JRockit 1.6_29 returns a null of the method invocation clazz.getDeclaringClass() in JoinPointGenerator.findAdvisedField(......);

    After I changed to the Sun JDK 1.6_29 everything works fine and clazz.getDeclaringClass() returns a non null value.