0 Replies Latest reply on Mar 9, 2012 11:55 PM by Janakiraman Elangovan

    Jboss-6.1.0-Final dependency error

    Janakiraman Elangovan Newbie

      Hi,

       

      Jboss Migration from 4.0.2-GA to 6.1.0-Final version as deployed successfully

       

      As we checked most of the links are working fine.

       

      But the deployment get success once we not include the backend process of power (i.e. Autorelease,Postprocess and Mail) in the config file such as

      jboss-web.xml and web.xml file.

       

      With include of these process it shows an deployment dependencies error.

       

      DEPLOYMENT DEPENDENCIES ERROR:

      Deployment "jboss-switchboard:appName=power, module=power" is missing the following dependencies:

      Dependency "java:/queue/autoReleaseQueue" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'java:/queue/autoReleaseQueue'**")

      Dependency "java:/queue/postProcessQueue" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'java:/queue/postProcessQueue'**")

      Dependency "java:/mail/Power" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'java:/mail/Power' **")

      Deployment "jboss.web.deployment:war=/power" is missing the following dependencies:

      Dependency "jboss-switchboard:appName=power, module=power" (should be in state "Installed", but is actually in state "Create")


      DEPLOYMENTS IN ERROR:
      Deployment "java:/queue/autoReleaseQueue" is in error due to the following reason(s): ** NOT FOUND Depends on 'java:/queue/autoReleaseQueue' **
      Deployment "java:/mail/Power" is in error due to the following reason(s): ** NOT FOUND Depends on 'java:/mail/Power' **
      Deployment "java:/queue/postProcessQueue" is in error due to the following reason(s): ** NOT FOUND Depends on 'java:/queue/postProcessQueue' **

       

      Without include these process the application deployed without an error.

       

      In Jboss 6.1.0-Final version it as the default messaging system (i.e. Hornetq process).

       

      Log trace :

       

      12:04:18,791 INFO  [HornetQServerImpl] live server is starting with configuration HornetQ Configuration (clustered=false,backup=false,sharedStore=true,journalDirectory=C:\jboss-6.1.0.Final\server\power\data/hornetq/journal,bindingsDirectory=C:\jboss-6.1.0.Final\server\power\data/hornetq/bindings,largeMessagesDirectory=C:\jboss-6.1.0.Final\server\power\data/hornetq/largemessages,pagingDirectory=C:\jboss-6.1.0.Final\server\power\data/hornetq/paging)

      12:04:18,791 INFO  [HornetQServerImpl] Waiting to obtain live lock

      12:04:20,474 INFO  [HornetQServerImpl] Server is now live

      12:04:20,490 INFO  [HornetQServerImpl] HornetQ Server version 2.2.5.Final (HQ_2_2_5_FINAL_AS7, 121) [39dd0735-2a12-11e1-a574-e0cb4ea218a0] started

      12:04:23,000 INFO  [HornetQResourceAdapter] HornetQ resource adaptor started

      12:04:56,956 INFO  [HornetQServerImpl] trying to deploy queue jms.queue.autoReleaseQueue

      12:04:57,050 INFO  [HornetQServerImpl] trying to deploy queue jms.queue.postProcessQueue

      12:04:57,066 INFO  [HornetQServerImpl] trying to deploy queue jms.queue.ExpiryQueue

      12:04:57,081 INFO  [HornetQServerImpl] trying to deploy queue jms.queue.DLQ

       

      Well I have configured the Queues in the hornetq-jms.xml file.

       

       

      Please help for the mentioned request.

       

      Thanks,

      Janakiraman E