4 Replies Latest reply on Mar 14, 2012 8:59 AM by Hannes Weninger

    JBoss 7 dependencies

    Hannes Weninger Newbie

      Hi,

       

      I have the following example- application http://www.file-upload.net/download-4184515/ProjektsWithException.rar.html which demonstrates my dependency problems,

      I get the following stack trace at the bottom.

       

      I have 2 Projects, at Project 1 I have the following MAIFEST.MF:

       

      Manifest-Version: 1.0

      Dependencies: org.apache.log4j.chainsaw

       

      and at Project 2 I have this Manifes.mf:

       

      Manifest-Version: 1.0

      Dependencies: org.apache.log4j.chainsaw export

       

      Project 1 includes Project 2 (in Eclipse at Deployment Assembly)

       

      Does anybody know what I have to do in order to avoid the exception at the bottom?

       

      Thanks a lot and all the best,

      Generic (Germany, Berlin)

       

      15:53:21,352 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC00001: Failed to start service jboss.module.service."deployment.JBoss7Test.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.JBoss7Test.war".main: Failed to load module: deployment.JBoss7Test.war:main
       at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:67) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]
       at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]
       at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]
       at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_20]
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_20]
       at java.lang.Thread.run(Thread.java:619) [:1.6.0_20]
      Caused by: org.jboss.modules.ModuleNotFoundException: Module org.apache.log4j.chainsaw:main is not found
       at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:121) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:245) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:194) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:97) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:176) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.Module.linkExports(Module.java:923) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.Module.linkExports(Module.java:846) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.Module.linkExportsIfNeeded(Module.java:1148) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:180) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:172) [jboss-modules.jar:1.0.2.GA]
       at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:63) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]
       ... 5 more