9 Replies Latest reply: Mar 14, 2012 7:13 PM by wei0313 RSS

    jsp not reflect changes

    wei0313 Newbie

      JSP not reflect changes after making modifications I am using JBoss7.1.0Final

      I have EAR and several .WARs in the EAR. I made modification in JSP in one of the WAR. However, JSP is not getting changed.

      I am new to JBoss and I am unsure if there's any flag I need to change or anything else I need to change to have JSP automatically reflect the changes?

       

      Thanks

      -A

        • 2. Re: jsp not reflect changes
          wei0313 Newbie

          Hi Jaikiran

           

          I have tried that link but I still don't see the changes getting reflected. Do you have any suggestions?

           

          Thanks

          -A

          • 3. Re: jsp not reflect changes
            jaikiran pai Master

            wei0313 wrote:

             

             

            I have tried that link but I still don't see the changes getting reflected. Do you have any suggestions?

            What does your config look like? Which exact file did you change and how are you starting the application? Are you deploying in exploded format or as an archive? Are you using any IDEs to deploy? What changes are you doing to the JSPs and how are you verifying that it doesn't work?

            • 4. Re: jsp not reflect changes
              wei0313 Newbie

              I put the <config...><jsp.... /></config...> under web: tag. I replaced in the standalone-xxx.xml this is our own config xml

              when start the application, i supply with the standalone-xxx.xml.

              it's a exploded EAR in standalone/deployment.  just copy the exploded EAR to the deployment folder to deploy.

              The changes on JSP : original JSP compiled and display fine and I added extra } to make jsp throw errors. however, JSP still showed up fine w/ the original content.

               

              Thanks

              -A

              • 5. Re: jsp not reflect changes
                jaikiran pai Master

                wei0313 wrote:

                 

                I put the <config...><jsp.... /></config...> under web: tag.

                Please post the exact contents.

                 

                 

                wei0313 wrote:

                 

                I replaced in the standalone-xxx.xml this is our own config xml

                when start the application, i supply with the standalone-xxx.xml.

                Did you restart the server after manually changing that file? Please also post the exact command you use to start the server.

                • 6. Re: jsp not reflect changes
                  wei0313 Newbie

                  <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host">

                              <configuration>

                                  <jsp-configuration development="true"/>

                              </configuration>

                              <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                              <connector name="default" protocol="AJP/1.3" scheme="http" socket-binding="default" enabled="true"/>

                              <virtual-server name="default-host" enable-welcome-root="true">

                                  <alias name="localhost"/>

                                  <alias name="example.com"/>

                              </virtual-server>

                          </subsystem>

                  • 7. Re: jsp not reflect changes
                    wei0313 Newbie

                    standalone.bat -server-config=standalone-xxx.xml to start the app

                    • 8. Re: jsp not reflect changes
                      jaikiran pai Master

                      I just tried this against 7.1.0.Final by first including a JSP which prints "Hello World" and then changing the message in the JSP to "GoodBye". The changes were picked up dynamically. I suggest you try this first with a simple application and use the standalone.xml that ships in the distribution. If that works then try it against your custom standalone-xxx.xml. That way we'll know which part is misconfigured.

                      • 9. Re: jsp not reflect changes
                        wei0313 Newbie

                        I have tried with simple ear which has one war and meta-inf ony and it worked fine.

                         

                        However with more complex ear which has 10 WARs, \lib, persistence.xml in the EAR, I am running into issues as the EAR is trying to undeploy all WARs and deploy again. However, I always get the following errors

                        13:07:37,919 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010403: Deploying JDBC-compliant driver class com.microsoft.sqlserver.jdbc.SQLServerDriver (version 3.0)

                        13:07:38,089 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010403: Deploying JDBC-compliant driver class org.apache.derby.jdbc.AutoloadedDriver (version 10.8)

                        13:07:38,091 WARN  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010402: Unable to instantiate driver class "org.apache.derby.jdbc.AutoloadedDriver": org.jboss.msc.service.DuplicateServiceException: Service jboss.jdbc-driver.xxx_ear is already registered

                        13:07:38,094 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010404: Deploying non-JDBC-compliant driver class org.postgresql.Driver (version 9.1)

                        13:07:38,096 WARN  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-2) JBAS010402: Unable to instantiate driver class "org.postgresql.Driver": org.jboss.msc.service.DuplicateServiceException: Service jboss.jdbc-driver.xxx_ear is already registered

                         

                        then jboss (carmel) shuts down. Any suggestions?