0 Replies Latest reply on Mar 15, 2012 1:18 PM by kowshik NS

    OSGI Bundle startup order in jboss-as-7.1.0.Final

    kowshik NS Newbie

      I have a problem in starting the OSGi plugins at the startup.

       

      My setup:

       

                 PluginA 

                 PluginB

                 Plugin C

       

      Plugin A - Independent

      Plugin B is depenent on Plugin A

      Plugin C is dependent on both plugin A and plugin B.

       

      I deploy this is in the same order .

       

      After I restart the server. Plugin  B is started before Plugin A. Plugins are created using Eclipse. Jboss version used is jboss-as-7.1.0.Final.

       

      Note: Running the server in domain mode and HA Profile.

       

      Manifest file of Plugin B has this entry:

      Require-Bundle: A;bundle-version="1.0.0"


      Manifest file of Plugin C has this entry:

      Require-Bundle: A;bundle-version="1.0.0",

      B;bundle-version="3.4.2",

       

       

       

      Thanks in Advance