2 Replies Latest reply on Dec 19, 2001 9:14 AM by Joel Riedesel

    jaws remove-table not working (3.0 alpha)

    Joel Riedesel Newbie

      I've tried setting the remove-table option to
      true in a jaws.xml in my META-INF for my
      ejbs with both default-entity and a specific
      bean. And I've finally tried it in the
      global standardjaws.xml. Nothing. My tables
      are not being removed.

      Is this supposed to work? How does one clean out
      their tables in hypersonic?

        • 1. Re: jaws remove-table not working (3.0 alpha)
          Jochen Cordes Novice

          Hi !

          You have to create a jbosscmp-jdbc.xml descriptor for your bean. There you can specify if tables should be created, removed or which kind of database you are using e.g

          <jbosscmp-jdbc>

          java:/MySQLDS
          <type-mapping>mySQL</type-mapping>
          true
          <create-table>true</create-table>
          <remove-table>true</remove-table>
          <read-only>false</read-only>
          <time-out>300</time-out>
          <select-for-update>false</select-for-update>
          <pk-constraint>false</pk-constraint>
          <preferred-relation-mapping>foreign-key</preferred-relation-mapping>


          <!-- your beans here -->
          </jbosscmp-jdbc>

          Hope it helps !

          Jochen.

          • 2. Re: jaws remove-table not working (3.0 alpha)
            Joel Riedesel Newbie

            Perfect. I should have figured that out since I
            had found the standardjbosscmp-jdbc.xml file and
            that had finally worked.
            I just tried jbosscmp-jdbc.xml and put it with my
            ejb jar and that's working wonderfully. Thanks
            for the tip.