0 Replies Latest reply on Mar 21, 2012 2:44 PM by kthegeek

    How do i set up tibco messaging in jboss 6.0?

    kthegeek Newbie

      Hi ,


      We are using current jboss 4.05 application server and we are migrating to an higher version jboss 6.0.

      I have successfully migrated most of the settings to 6.0 and deployed the components .But facing issues in setting up tibco messaging .

      I couldnt find any documentation on this .


      We have a jms-ds.xml



           <mbean code="org.jboss.jms.jndi.JMSProviderLoader" name=":service=JMSProviderLoader,name=TibjmsProvider">

                <attribute name="ProviderName">TIBCOJMSProvider</attribute>

                <attribute name="ProviderAdapterClass">org.jboss.jms.jndi.JNDIProviderAdapter</attribute>

                <attribute name="QueueFactoryRef">XQueueConnectionFactory</attribute>

                <attribute name="TopicFactoryRef">XTopicConnectionFactory</attribute>

                <attribute name="Properties">







      I have added in to the deploy directory and have the ejb components in the deploy directory .


      I get an error in server log


      jboss.jca:service=RARDeployment,name='jms-ra.rar' is not registered.

        Deployment "jboss.j2ee:binding=cpas-MessageBean-invoker,jndiName=local/MessageBean@28668684,plugin=invoker,service=EJB" is in error due to the following reason(s): javax.management.InstanceNotFoundException: jboss.jca:service=RARDeployment,name='jms-ra.rar' is not registered.


      We are not using hornetq so i removed the jar related to it from lib and also from jms-ra.rar.jms-ra.rar/ra.xml has setting only for hornetq.

      Can some one please help me in resolving this issue and migrating the settings for jboss 6.0