7 Replies Latest reply on Mar 26, 2012 10:07 AM by Paul Ferraro

    Jboss 6.0 and Mod_Cluster 1.2.0

    JBoss Fan Newbie

      Hi Gururs,

       

      I 'am trying to make mod_cluster via apache 2.2.22 with Jboss 6.0 Final. I was able to get to work with my app on application server directly via 8080 port.. I run apache on 80 port and hit mod_cluster-manager on 80 port.. however my nodes won;t show up or am unable to me hit my application via apache I host.

       

      this is in my http server

       

      MemManagerFile /apps/cache/httpd

      <VirtualHost *:80>

      <Directory />

      Order deny,allow

      Allow from all

      </Directory>

      KeepAliveTimeout 60

      MaxKeepAliveRequests 0

      ManagerBalancerName mycluster

      AdvertiseFrequency 5

      </VirtualHost>

      <Location /mod_cluster-manager>

      SetHandler mod_cluster-manager

      Order deny,allow

      Allow from all

      </Location>

       

      Please let me know how to troubleshoot this.. issue

       

      S

        • 1. Re: Jboss 6.0 and Mod_Cluster 1.2.0
          Radoslav Husar Master

          First thing is to check if the nodes are showing up in mod_cluster manager. If they arent, then the context cannot be routed.

           

          Check your AS6 logs as well. If multicasting is not working, the set the proxy-list in AS6 config.

           

          But you should make your config safe first. The registering should be done on 6666 port for example open only to your internal network but you are allowing to all, so now anyone could register their AS7 node with your balancer.

           

          PS: If you are still developing your app you should consider moving to AS7 instead of AS6.

          • 2. Re: Jboss 6.0 and Mod_Cluster 1.2.0
            JBoss Fan Newbie

            Hi Husar,

             

             

            Thanks for the reply..

             

             

            When I hit my webserver on http://<hostname>:6666

             

            I get default age served

            It works!

             

             

             

             

            and I changed my mod_cluster section info...

             

            Listen 10.36.10.12:6666

            MemManagerFile /apps/cache/httpd

            <VirtualHost 10.36.10.12:6666>

            <Directory />

            Order deny,allow

            Deny from all

            Allow from 10.36.

            </Directory>

            KeepAliveTimeout 60

            MaxKeepAliveRequests 0

            ManagerBalancerName mycluster

            AdvertiseFrequency 5

            </VirtualHost>

            <Location /mod_cluster-manager>

            SetHandler mod_cluster-manager

            Order deny,allow

            Deny from all

            Allow from 10.36.

            </Location>

             

             

             

            on mod_cluster-manager this is what I get and no nodes info

             

            mod_cluster/1.2.0.Final

            Auto Refresh show DUMP output show INFO output

             

             

            if I start using proxy-list in mod_cluster-jboss-beans.xml file in mod_cluster.sar/METAINF

             

            am getting this error in boot.log

             

            06:42:51,640 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] Error [null: null: {4}] sending command INFO to proxy sb.mysandbox.real/10.36.10.12:6666, configuration will be reset

            06:43:01,666 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] Error [null: null: {4}] sending command INFO to proxy sb.mysandbox.real/10.36.10.12:6666, configuration will be reset

             

             

             

             

            S

            • 3. Re: Jboss 6.0 and Mod_Cluster 1.2.0
              jmascreen Newbie

              Add the following lines in httpd.conf and see

               

                  ServerAdvertise On

                  EnableMCPMReceive

              • 4. Re: Jboss 6.0 and Mod_Cluster 1.2.0
                Michal Karm Babacek Apprentice

                I concur. MCMP messages are being processed only within those VirtualHosts that have EnableMCPMReceive directive set.

                • 5. Re: Jboss 6.0 and Mod_Cluster 1.2.0
                  jmascreen Newbie

                  Modify as below

                   

                  <Engine name="jboss.web" defaultHost="localhost"> to

                  <Engine name="jboss.web" defaultHost="localhost" jvmRoute="${jboss.jvmRoute}">

                   

                  in PROFILE/deploy/jbossweb.sar/server.xml

                   

                  AND

                   

                  Unicast to 224.0.0.0

                  • 6. Re: Jboss 6.0 and Mod_Cluster 1.2.0
                    JBoss Fan Newbie

                    Thanks to all of you... you really made my cluster works.. Jboss Rocks.. everythign si workign fine for me now..

                     

                    Although my cluster is working.. I have a couple of questions from the documentation am reading..

                     

                    is this change required in server.xml file ?

                     

                     

                    <Listener className="org.jboss.web.tomcat.service.deployers.MicrocontainerIntegrationLifecycleListener" delegateBeanName="HAModClusterService"/>

                     

                    if I have this change it errors out..

                     

                    Also in jbossweb.sar/META-INF/jboss-beans.xml is this change required..

                     

                    <depends>HAModClusterService</depends>

                     

                     

                    Like I said my cluster works perfectly.. but want to know what difference above 2 paramaters/changes make ? and how to start up my cluster without errors. ?

                     

                     

                     

                    S

                    • 7. Re: Jboss 6.0 and Mod_Cluster 1.2.0
                      Paul Ferraro Master

                      The short answer - those configuration changes are not relevant to AS6.

                       

                      You don't need to define a <Listener/> for use in AS6 - the appropriate listener will be added automagically.

                       

                      You also don't want to add that dependency (i.e. on HAModClusterService) to the jbossweb mc config.  mod_cluster integration was improved in AS6 such that the web container no longer needs to depend on mod_cluster - instead, mod_cluster depends on the web container.  This reversal makes for confusing documentation unfortunately - so sorry for the confusion.