3 Replies Latest reply on Jan 3, 2002 8:45 AM by Chris

    jboss3a - "can't find datasource" when deploying CMP2.0 bean

    Mark Hesketh Newbie

      I've read a few other posts regarding this and I've tried to see what's what with http://localhost:8082, etc.. to no avail... :(

      I've been trawling the doco for configuring PostgreSQL and I've deployed with the beans a jaws.xml and a postgresql-service.xml using Chap3's definition for the latter.

      Can someone tell me why I now get the following stack trace upon deployment?: (Note: This leads to a later "Can't find data source" exception/msg).

      [22:00:17,616,PostgreSQL] Stopped
      javax.management.RuntimeOperationsException: Object name cannot be null
      at com.sun.management.jmx.MBeanServerImpl.isRegistered(MBeanServerImpl.j
      ava:1096)
      at org.jboss.resource.ConnectionFactoryLoader.startService(ConnectionFac
      toryLoader.java:402)
      at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:1
      17)
      at java.lang.reflect.Method.invoke(Native Method)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:16
      28)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:15
      23)
      at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceControl
      ler.java:775)

      cheerz.
      Mark

        • 1. Re: jboss3a -
          David Jencks Master

          I suspect you missed the configuration changes between jboss 3.0 alpha and the cvs version. The cvs version is documented in ch 3 of the manual.

          3.0 alpha needs tags like
          <mbean-ref name="...">...</mbean-ref.

          cvs needs tags like
          <depends optional-attribute-name="...">...

          • 2. Re: jboss3a -
            Mark Hesketh Newbie

            This seems fixed now - I'm now using 'localhost' rather than my real hostname.

            Mark

            • 3. Re: jboss3a -
              Chris Newbie

              I had another similar problem...

              I copied the file classes12.zip into lib/ext &
              took the sample OracleDS file (referencing classes12.zip) from the docs - but it could not find the oracle driver.

              But if I changed the name to classes12.jar and (subsequently the name of the archive in the oracleDS xml file) then it worked!