0 Replies Latest reply on Mar 29, 2012 4:22 PM by Tony Kaska

    PicketLink 2.0.3 on JBoss AS 7.1.1 getting started problem

    Tony Kaska Newbie

      I am trying to have PicketLink 2.0.3 work with JBoss AS 7.1.1. My goal is to get IDM sample work first. The war samples work. But I want to build and compile the samples so that I can understand how to build and IDM for our project. That is the approach suggested in your documentation.


      I downloaded the sample program for IDM from the svn.




      But I am running into the following problem when I try to compile. Am I picking the sample from the right place? In several places in your literature it recommends to start with sample programs. I am assuming you want us to compile and try the program than just review the code and understand the concepts.


      I wanted to start with IDM. Then I wanted try IDP and SP and the Federation aspects. But I am not able to get past successfully dealing with IDM. Your help will be appreciated. Right now I am using JBoss AS 7.1.1 and PicketLink 2.0.3. I tried replacing 2.0.0-SNAPSHOT with 2.0.3 and still no luck. I have been spending considerable amount of time for the past 4 or 5 days to build an IDM application and then use SAML Federation using your PicketLink solution but I am not successful. Some pointers to get started with right foot will be really appreciated.


      I have two setups ready to test. JBoss 7.1.1 with Picket Link 2.0.3. I also have 7.1.0 and Picket Link 2.0.2. All the sample wars run OK in that. (Thanks to Anil, Pedro. They are doing a great hand holding of users. Glen Mazza and Gerry Matte are excellent active users).


      I have been developing using Microsoft Technology for a long time. Recently swiched sides to Java for a business critical project. While our company and everyone were sold on Spring is the way to go, I convinced them that JBoss AS 7 and CDI is the way to go. I love JBoss 7 and its efficiency. I respect the leadership in their contribution for the JEE6 based on their Seam 2 success. Actually I have a CDI based prototype working well for my project with AS 7.1.1. All that is missing is incorporating role based security. My mission and picking JBoss 7 looks very promising. But I need to get started with IDM. So your help will be appreciated.


      PicketLink is very brilliant architecture in my opinion. Also you have taken lot of consideration to offer powerful features very simply. From Microsoft to any open source, no one is talking about Identity Management as an independent architectural piece with SAML federation and all those federation aspects supported so well. For some reason I am not able to make it work. So looking for some help. Compared to 7.1.0 and 2.0.2 and 7.1.1 and 2.0.2 I think 7.1.1 and 2.0.3 was easy to basic samples working. Now how to develop the actual IDM solutions and taking it further with SAML IDP is the challenge.


      Or if you think if there is any other way to get familiar with IDM and your Federation solution without actually running the samples, please let me know.


      [INFO] Scanning for projects...


      [WARNING] Some problems were encountered while building the effective model for org.picketlink.idm:picketlink-idm-testsuite:jar:2.0.0-SNAPSHOT

      [WARNING] 'parent.relativePath' of POM org.picketlink.idm:picketlink-idm-parent:2.0.0-SNAPSHOT (C:\Users\tk\idm\2.0.0\parent\pom.xml) points at org.picketlink.idm:jboss-identity-idm-pom instead of org.jboss:jboss-parent, please verify your project structure @ org.picketlink.idm:picketlink-idm-parent:2.0.0-SNAPSHOT, C:\Users\tk\idm\2.0.0\parent\pom.xml, line 2, column 12


      [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.


      [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.



      [INFO] ------------------------------------------------------------------------

      [INFO] Building PicketLink IDM Testsuite 2.0.0-SNAPSHOT

      [INFO] ------------------------------------------------------------------------

      [WARNING] The POM for org.picketlink.idm:picketlink-idm-cache:jar:2.0.0-SNAPSHOT is missing, no dependency information available

      [WARNING] The POM for org.picketlink.idm:picketlink-idm-hibernate:jar:2.0.0-SNAPSHOT is missing, no dependency information available

      [WARNING] The POM for org.picketlink.idm:picketlink-idm-ldap:jar:2.0.0-SNAPSHOT is missing, no dependency information available

      [WARNING] The POM for org.picketlink.idm:picketlink-idm-core:jar:tests:2.0.0-SNAPSHOT is missing, no dependency information available

      SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".

      SLF4J: Defaulting to no-operation (NOP) logger implementation

      SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

      Downloading: http://repository.jboss.org/maven2/sun-opends/OpenDS/1.0.0/OpenDS-1.0.0.pom

      Downloading: http://repository.jboss.org/maven2/org/jboss/unit/portal-test/1.2.2/portal-test-1.2.2.pom

      Downloading: http://repository.jboss.org/maven2/jboss/jbossas/core-libs/jboss-local-jdbc/4.0.4.GA/jboss-local-jdbc-4.0.4.GA.pom

      Downloading: http://repository.jboss.org/maven2/jboss/jbossas/core-libs/jboss-common-jdbc-wrapper/4.0.4.GA/jboss-common-jdbc-wrapper-4.0.4.GA.pom

      Downloading: http://repository.jboss.org/maven2/jboss/jboss-logging-log4j/2.0.2.GA/jboss-logging-log4j-2.0.2.GA.pom

      [INFO] ------------------------------------------------------------------------


      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 1.667s

      [INFO] Finished at: Thu Mar 29 02:15:46 CDT 2012

      [INFO] Final Memory: 6M/15M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Failed to execute goal on project picketlink-idm-testsuite: Could not resolve dependencies for project org.picketlink.idm:picketlink-idm-testsuite:jar:2.0.0-SNAPSHOT: Failed to collect dependencies for [org.picketlink.idm:picketlink-idm-cache:jar:2.0.0-SNAPSHOT (compile), org.picketlink.idm:picketlink-idm-hibernate:jar:2.0.0-SNAPSHOT (compile), org.picketlink.idm:picketlink-idm-ldap:jar:2.0.0-SNAPSHOT (compile), org.picketlink.idm:picketlink-idm-core:jar:tests:2.0.0-SNAPSHOT (test), junit:junit:jar:4.4 (test), hsqldb:hsqldb:jar: (test), sun-opends:OpenDS:jar:1.0.0 (test), berkeleydb:je:jar:3.2.76 (test), org.jboss.unit:portal-test:jar:1.2.2 (test), jboss.jbossas.core-libs:jboss-local-jdbc:jar:4.0.4.GA (test), jboss.jbossas.core-libs:jboss-common-jdbc-wrapper:jar:4.0.4.GA (test), jboss:jboss-logging-log4j:jar:2.0.2.GA (test), net.sourceforge.jtds:jtds:jar:1.2.2 (test)]: Failed to read artifact descriptor for sun-opends:OpenDS:jar:1.0.0: Could not transfer artifact sun-opends:OpenDS:pom:1.0.0 from/to repository.jboss.org (http://repository.jboss.org/maven2): Access denied to http://repository.jboss.org/maven2/sun-opends/OpenDS/1.0.0/OpenDS-1.0.0.pom. Error code 403, Forbidden -> [Help 1]


      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.


      [ERROR] For more information about the errors and possible solutions, please read the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException



      Again thank you for looking into this and thank you for your help.