3 Replies Latest reply on Sep 13, 2012 12:06 AM by Mayank Gupta

    Jboss hangs on EJB 2.1 entity calls

    Michael Rootman Newbie

      Hi All,


      We are migrating our project with EJB 2.1 from Jboss 5.1 to Jboss 7.1.1


      One of the issues, that we are facing is call to EJB 2.1 entity beans methods.

      Beans successfully deployed and can be obtained through JNDI call, though any call to entity finder results in Jboss hanging 

      There is no exception thrown and no log records. Jboss simply stuck and does  not return response back.

      Eclipse debug shows, that last accessible line is 71 on ProxyInvocationHandler.


      Any suggestions?

        • 1. Re: Jboss hangs on EJB 2.1 entity calls
          jaikiran pai Master

          What exactly do you mean by a hang? Can you get a thread dump http://community.jboss.org/wiki/ThreadDump when it hangs?

          • 2. Re: Jboss hangs on EJB 2.1 entity calls
            Carsten Maneg Newbie

            Hello Michael,


            any news to your problem?

            I have similar issue and solution is very important.





            • 3. Re: Jboss hangs on EJB 2.1 entity calls
              Mayank Gupta Newbie

              Hello All,


              I am also facing the same issue. In my case I am calling a Entity bean method from a SLSB instance.

              For both bean method's transaction attribute is Required.


              I tried to change the Entity beans transaction attribute to SUPPORTS, MANDATORY but in none of the case it works.

              Same code is working on JBOSS 4 and 6.


              When the server hangs up completely I ran a Oracle query to find the DB level locks at that time but for surprise there were NO DB locks.

              It seems to be a problem completely on JBOSS7 server side.

              I also tried to run my application on latest JBOSS7 nightly build on 11 sept 2012 and problem is still reproducible on that version.


              I tried to debug the JBOSS7 invocation jar code and it hangs somewhere in interceptor chain.


              More Update:

              Code hangs up in EntityBeanSynchronizationInterceptor while taking lock on transactionSynchronizationRegistry.

              lock.lock; hangs up //line 80

              When Arjuna Manager timeouts the EJB transaction then it comes out and we finally get transaction rollback exception.

              Also problem occurs when lockOwner is not the currentRequester which means transaction was started by previous thread in

              same transaction. Above all this does not always occurs but I think could occur if the same Entity Instance was already bound as that could be in use

              from previous transaction and here we again try to aquire a lock on it.


              JIRA has been raised for this issue


              If needed I will try to give a sample application demostrating the bug in JBOSS7 Entity Interceptor stack.