2 Replies Latest reply on Nov 18, 2012 4:57 PM by sebastian8712

    JAAS \ jboss-as-7.1.1.Final \ Seam 3.1.0.Final

    Michael Anstis Newbie

      Hi,

       

      I am having problems configuring JAAS with AS7 (and potentially Seam 3.1.0.Final \ WELD 1.1.Final as these are both use by my application too).

       

      If I don't use <security:authenticatorName>jaasAuthenticator</security:authenticator> the application deploys fine and is accessible from it's corresponding URL.

       

      If however I have the entry in my beans.xml file the WAR deploys OK, but AS7 reports the resouce is unavailable when trying to access from it's corresponding URL.

       

      I enabled TRACE logging and there is nothing (I can see) that suggests there was a failure somewhere - indeed it suggests deployment (and enabling) of the JAAS enabled WAR was successful.

       

      I'm no AS or Seam expert (other than what I've read over the past couple of days), but suspect there are others on here who perhaps are.

       

      Here's an extract from my Seam beans.xml file:-

       

        <security:IdentityImpl>

          <s:modifies/>

          <security:authenticatorName>jaasAuthenticator</security:authenticatorName>

        </security:IdentityImpl>

       

        <security:jaas.JaasAuthenticator>

          <s:modifies/>

          <jaasConfigName>other</jaasConfigName>

        </security:jaas.JaasAuthenticator>

       

      These are the extracts from my (default) standalone.xml:-

       

          <management>

              <security-realms>

                  <security-realm name="ManagementRealm">

                      <authentication>

                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

                  <security-realm name="ApplicationRealm">

                      <authentication>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

              </security-realms>

              <management-interfaces>

                  <native-interface security-realm="ManagementRealm">

                      <socket-binding native="management-native"/>

                  </native-interface>

                  <http-interface security-realm="ManagementRealm">

                      <socket-binding http="management-http"/>

                  </http-interface>

              </management-interfaces>

          </management>

      ...

       

          <subsystem xmlns="urn:jboss:domain:security:1.1">

                  <security-domains>

                      <security-domain name="other" cache-type="default">

                          <authentication>

                              <login-module code="Remoting" flag="optional">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                              <login-module code="RealmUsersRoles" flag="required">

                                  <module-option name="usersProperties" value="${jboss.server.config.dir}/application-users.properties"/>

                                  <module-option name="rolesProperties" value="${jboss.server.config.dir}/application-roles.properties"/>

                                  <module-option name="realm" value="ApplicationRealm"/>

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      <security-domain name="jboss-web-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                      <security-domain name="jboss-ejb-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                  </security-domains>

              </subsystem>

       

      Any help of pointers from the AS7 commnuity would be welcome.

       

      With kind regards,

       

      Mike