0 Replies Latest reply on Apr 4, 2012 11:27 PM by jabir mk

    JBoss 5.1.0 startup exception

    jabir mk Newbie

      I'm using JBoss 5.1.0 on linux/solaris and I could see the following error happening during startup time if I enable DEBUG logs.This error keeps on getting printed for more than 100 times.

      09:12:52,767 FINE  [tcp] RMI TCP Connection(1)-10.0.10.1: (port 1098) op = 82
      09:12:52,770 FINE  [tcp] RMI TCP Connection(1)-10.0.10.1: (port 1098) op = 80
      09:12:52,772 FINE  [loader] RMI TCP Connection(1)-10.0.10.1: name = "javax.naming.CompoundName", codebase = "http://myhost:8183/", defaultLoader = BaseClassLoader@3e584d{vfsfile:/export/home/jboss/server/myserver/conf/jboss-service.xml}
      09:12:52,775 FINE  [loader] RMI TCP Connection(1)-10.0.10.1: name = "org.jnp.interfaces.FastNamingProperties", codebase
      = "http://myhost:8183/", defaultLoader = BaseClassLoader@3e584d{vfsfile:/export/home/jboss/server/myserver/conf/jboss-serv
      ice
      .xml}
      09:12:52,777 FINE  [loader] RMI TCP Connection(1)-10.0.10.1: name = "java.util.Properties", codebase = "http://myhost:8
      183/"
      , defaultLoader = BaseClassLoader@3e584d{vfsfile:/export/home/jboss/server/myserver/conf/jboss-service.xml}
      09:12:52,782 FINE  [loader] RMI TCP Connection(1)-10.0.10.1: name = "java.util.Hashtable", codebase = "http://myhost:81
      83/"
      , defaultLoader = BaseClassLoader@3e584d{vfsfile:/export/home/jboss/server/myserver/conf/jboss-service.xml}
      09:12:52,786 FINE  [call] RMI TCP Connection(1)-10.0.10.1: [10.0.10.1] exception:
      javax
      .naming.NameNotFoundException: topic not bound
              at org
      .jnp.server.NamingServer.getBinding(NamingServer.java:771)
              at org
      .jnp.server.NamingServer.getBinding(NamingServer.java:779)
              at org
      .jnp.server.NamingServer.getObject(NamingServer.java:785)
              at org
      .jnp.server.NamingServer.lookup(NamingServer.java:396)
              at sun
      .reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun
      .reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
              at sun
      .reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java
      .lang.reflect.Method.invoke(Unknown Source)
              at sun
      .rmi.server.UnicastServerRef.dispatch(Unknown Source)
              at sun
      .rmi.transport.Transport$1.run(Unknown Source)
              at java
      .security.AccessController.doPrivileged(Native Method)
              at sun
      .rmi.transport.Transport.serviceCall(Unknown Source)
              at sun
      .rmi.transport.tcp.TCPTransport.handleMessages(Unknown Source)
              at sun
      .rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(Unknown Source)
              at sun
      .rmi.transport.tcp.TCPTransport$ConnectionHandler.run(Unknown Source)
              at java
      .util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
              at java
      .util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
              at java
      .lang.Thread.run(Unknown Source)

      Does this cause any problem?especially start up delay?

      Any tip/suggestion highly appreciated.