1 Reply Latest reply on Apr 11, 2012 12:13 AM by Santhosh TR

    jsf-impl-2.1.7-jbossorg-2.jar (Shipped with jboss-as-7.1.1.Final)is missing MANIFEST entries

    Santhosh TR Newbie

      Hi,

       

      I'm trying to create a very simple OSGi enabled JSF application as part of my research activities. I'm able to deploy the osgi-fied war in eclipse virgo by adding the jsf library in the server (

      JSF API + IMPL from http://download.java.net/maven/2/org/glassfish/javax.faces/2.1.2/. ). But when Tried to deploy the war in my jboss-as-7.1.1.Final i'm getting an error

       

      Caused by: org.jboss.osgi.resolver.XResolverException: Unable to resolve Module[osgijsf:1.0.0.qualifier]: missing requirement [Module[osgijsf:1.0.0.qualifier]] module; (bundle-symbolic-name=org.glassfish.com.sun.faces)

              at org.jboss.osgi.resolver.felix.FelixResolver.resolveInternal(FelixResolver.java:117) [jbosgi-resolver-felix-1.0.13.Final.jar:1.0.13.Final]

              at org.jboss.osgi.resolver.spi.AbstractResolver.resolve(AbstractResolver.java:149) [jbosgi-resolver-spi-1.0.13.Final.jar:1.0.13.Final]

              at org.jboss.osgi.framework.internal.ResolverPlugin.resolve(ResolverPlugin.java:155) [jbosgi-framework-core-1.1.8.Final.jar:1.1.8.Final]

              ... 11 more

      When I checked the "jsf impl" shipped with jboss-as-7.1.1.Final it seems the manifest is missing the entries for a jsf bundle, it only says

       

      Manifest-Version: 1.0

      Ant-Version: Apache Ant 1.8.2

      Created-By: 1.6.0_30-b12 (Sun Microsystems Inc.)

       

      as opposed to the manifest entries for entries for jsf-impl-2.1.5-jbossorg-1.jar [ http://hudson.jboss.org/jenkins/job/JBoss-AS-7.0.x-TattleTale/javadoc/jar/jsf-impl-2.1.5-jbossorg-1.jar.html]. Is this the reason behind jBoss is throwing the XResolverException while i'm deploying the war? Or I'm I missing some thing else? Please help.

       

      Note : If needed i'can attach my sample program for your perusal.

       

       

      Thanks and Regards,

      San Kallada.

        • 1. Re: jsf-impl-2.1.7-jbossorg-2.jar (Shipped with jboss-as-7.1.1.Final)is missing MANIFEST entries
          Santhosh TR Newbie

          Hi All,

           

          I'm still stuck with this issue. The manifest for for my application is as follows

           

           

          Manifest-Version: 1.0

          Bundle-ManifestVersion: 2

          Bundle-Name: osgijsf

          Bundle-SymbolicName: osgijsf

          Bundle-Version: 1.0.0.qualifier

          Bundle-ClassPath: WEB-INF/classes

          Require-Bundle: org.glassfish.com.sun.faces

          Bundle-RequiredExecutionEnvironment: JavaSE-1.6

          Web-ContextPath: /osgijsf

          Import-Package: javax.servlet;version="2.5",

          javax.el;version="2.0";resolution:=optional,

          javax.servlet.jsp.el;version="2.0",

          javax.servlet.jsp.tagext;version="2.0",

          javax.servlet.annotation;resolution:=optional,

          javax.servlet.jsp;version="2.0",

          javax.servlet.http;version="2.5"

          I my eclipse, to create the bundles, I'm using "IBM® Rational® Development Tools for OSGi Applications Plugin". But when I specify the "Require-Bundle: org.glassfish.com.sun.faces" in the application's(war) manifest file it gives me an error "Bundle 'org.glassfish.com.sun.faces' cannot be resolved" by eclipse. I have added the JBoss Drools in the applications class path too.

           

          Please help me by giving some pointers to solve this issue.

           

          Thanks and Regards,

          San Kallada