2 Replies Latest reply on Jan 22, 2002 1:48 AM by Bani Greyling

    record deletion

    Sachin Newbie

      Hi all,
      i am using jboss 2.4.3 with tomcat 3.2.3.
      All features of my application work fine except the deletion feature.
      I am using bmp. My architecture is JSP - Session Bean-Entity bean.
      As i click on the delete link on my jsp, the record does not get deleted. Its unpredictable. Sometimes it deletes, but the gui does not reflect the latest changes. Sometimes, the server hangs up. In all cases, all my code gets executed(i traced this).
      I am using BMT. Session bean method is declared as 'REquired' and the corresponding entity bean method that is ejbRemove is declared 'Mandatory'.
      I have tried this on Oracle 8 and also Postgres.
      I thought that i might be wrong in handling transaction attributes, but now it seems that the problem lies somewhere else.
      I have run the whole application on sun's j2ee server adn everything is fine.

      Please help me with the solution.
      Thanks in advance,
      Sachin

        • 1. Re: record deletion
          Sachin Newbie

          Hi All,
          Just a correct in the above post. I am using BMP and CMT.

          Also i have noticed one thing that if i restart teh jboss server, it allows me to delete the record and the gui gets refreshed as expected. But its for once only. The next record i try to delete, the server freezes and nothing happens. Also the other functionalities of update and insert can be carried out more than once. The only problem is delete.

          Have tried with setting commit option B, but did not help.

          Sachin

          • 2. Re: record deletion
            Bani Greyling Newbie

            I made some posts in topic "Please help! Load failed". Check that out as well.