3 Replies Latest reply on Apr 13, 2012 7:44 PM by Lance Goforth

    Error loading entity new on JB AS 7.1

    Lance Goforth Newbie

      I've got an application that I've been working on under JBoss 5, then I moved it to 6.  Now I'm running under AS 7.1.  One of my tests to load an object entity is failing under 7.1 although it worked fine under the other versions.


      I've traced it down to an attribute that is using @Formula to load the value.  It seems to be generating the sql with the table prefix on the formula, rather than just using the formula itself. 


      I've not been about to exactly confirm that is the issue - although I did pinpoint it down to that @Forumla statement.  The log is printing all sql up to, but no including the one that is failing.  I'm guessing the error is superseeding the print of the sql. 


      Any suggestions would be appreciated - even how to get it to print out the generated SQL prior to the error being thrown so I could verify exactly what it's doing.


      I tried upgrading the hibernate jars from 4.0.1 to 4.1.2 - that didn't seem to make any difference.