3 Replies Latest reply on Apr 17, 2012 10:40 AM by Andy Taylor

    JCA Adapter and Websphere AS 6.1

    ldentella Newbie

      Hello!

       

      I'm trying to install HornetQ JCA Adapter in Websphere Application Server 6.1.

       

      WAS 6.1 is based on J2EE 5.0 and when I try to install hornetq-ra.rar I get the following error:

       

      javax.management.MBeanException: Exception thrown in RequiredModelBean when trying to invoke operation getResourceAdapterFromRAR

      [...]

      Caused by: java.lang.UnsupportedClassVersionError: (org/hornetq/ra/HornetQResourceAdapter) bad major version at offset=6

       

      I assume my HornetQ RA (got from 2.2.5 archive) requires Java 6... is there JCA Adapter for Java 5?

      Thanks!