1 Reply Latest reply on Jul 15, 2014 12:45 AM by gopi balagala

    Error deploying Liferay 6.1 on Jboss 7.1.1 - Failed to start service jboss.module.service

    anthony.t Newbie

      Hi all,

       

      I am trying to deploy Liferay 6.1 on Jbss 7.1.1.

       

      I haven't problems to deploy in Jboss 7.0.2,  but when i try to deploy in 7.1.1, i get an exception:

       

      11:07:26,178 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.module.service."deployment.liferay.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.liferay.war".main: Failed to load module: deployment.liferay.war:main

      at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:91) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_22]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_22]

              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_22]

      Caused by: org.jboss.modules.ModuleNotFoundException: Module system:main is not found in local module loader @4229ab3e (roots: /opt/jboss-as-7.1.1.Final/modules)

                      …

       

      What is wrong?

       

      Thanks.