0 Replies Latest reply on Apr 26, 2012 6:20 PM by Julian Kiper

    url-delimiter not recognized in ha-local-tx-datasource??

    Julian Kiper Newbie

      Hi, I've this DS in JBOSS 4.3:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <datasources>

        <ha-local-tx-datasource>

          <jndi-name>defaultDST</jndi-name>   

          <driver-class>com.ibm.db2.jcc.DB2Driver</driver-class>

          <connection-url>jdbc:db2://10.0.0.10:60000/DBHADR1|jdbc:db2://10.0.0.20:60000/DBHADR2</connection-url>

          <url-delimiter>|</url-delimiter>

          <user-name>user</user-name>

          <password>pass</password>   

          <connection-property name="currentSchema">DBHADR1</connection-property>   

                <connection-property name="retryIntervalClientReroute">2</connection-property>

          <connection-property name="maxRetriesForClientReroute">10</connection-property>

          <connection-property name="enableClientAffinitiesList">1</connection-property>     

          <min-pool-size>20</min-pool-size>

          <max-pool-size>200</max-pool-size>

          <prepared-statement-cache-size>1000</prepared-statement-cache-size>

          <check-valid-connection-sql>SELECT CURRENT TIMESTAMP FROM SYSIBM.SYSDUMMY1 for read only</check-valid-connection-sql>   

          <idle-timeout-minutes>15</idle-timeout-minutes>

            <metadata>

               <type-mapping>DB2</type-mapping>

            </metadata>

        </ha-local-tx-datasource>

      </datasources>

       

      When trying to connect to the database, I'm receiving an error like if JBOSS is not detecting the URL delimiter as it reclaims for the whole string in connection-url....

       

      Any help would be appreciated!!!

       

      Thanks in advance.