0 Replies Latest reply on Apr 27, 2012 10:13 AM by Hauke Mehrtens

    Sun metro in Jboss 7.1

    Hauke Mehrtens Newbie

      I am currently working on porting our application from JBoss 5.1 to JBoss 7.1.1 with java 1.7u4. We replaced the JBoss Webservice stack with metro 2.0.1 and our application depends on metro.

      I got it so far that I do got get some "easy" to fix class not found exceptions, but now I get the following exception and do not know what is wrong or missing:

      16:02:50,026 SEVERE [com.sun.xml.ws.server.http] (MSC service thread 1-4) WSSERVLET11: failed to parse runtime descriptor: javax.xml.ws.WebServiceException: com.sun.xml.ws.policy.PolicyException: WSP1015: Server side assertion validation failed for "{http://schemas.sun.com/2006/03/wss/server}CallbackHandlerConfiguration" assertion. Assertion was evaluated as "UNKNOWN".: javax.xml.ws.WebServiceException: com.sun.xml.ws.policy.PolicyException: WSP1015: Server side assertion validation failed for "{http://schemas.sun.com/2006/03/wss/server}CallbackHandlerConfiguration" assertion. Assertion was evaluated as "UNKNOWN".
           at com.sun.xml.ws.policy.DefaultPolicyResolver.validateServerPolicyMap(DefaultPolicyResolver.java:96) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.policy.DefaultPolicyResolver.resolve(DefaultPolicyResolver.java:59) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.policy.PolicyWSDLParserExtension.postFinished(PolicyWSDLParserExtension.java:955) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.wsdl.parser.DelegatingParserExtension.postFinished(DelegatingParserExtension.java:187) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.wsdl.parser.WSDLParserExtensionFacade.postFinished(WSDLParserExtensionFacade.java:334) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.wsdl.parser.RuntimeWSDLParser.parse(RuntimeWSDLParser.java:262) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.server.EndpointFactory.getWSDLPort(EndpointFactory.java:531) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:174) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:505) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parseAdapters(DeploymentDescriptorParser.java:253) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parse(DeploymentDescriptorParser.java:147) [webservices-rt.jar:1.0]
           at com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:124) [webservices-rt.jar:1.0]
           at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.13.Final.jar:]
           at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.13.Final.jar:]
           at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]
           at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
           at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_04]
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_04]
           at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_04]
      Caused by: com.sun.xml.ws.policy.PolicyException: WSP1015: Server side assertion validation failed for "{http://schemas.sun.com/2006/03/wss/server}CallbackHandlerConfiguration" assertion. Assertion was evaluated as "UNKNOWN".
           at com.sun.xml.ws.policy.DefaultPolicyResolver.validateServerPolicyMap(DefaultPolicyResolver.java:88) [webservices-rt.jar:1.0]
           ... 19 more

       

      The module for metro looks like this: http://pastebin.com/4g6nfb0k (inline xml seams to be not possible))

      * I removed all references to webservices in the standalone.xml

      * I removed the "<module name="org.jboss.modules"/>" from "modules/javax/xml/soap/api/main/module.xml" and "modules/javax/xml/ws/api/main/module.xml" like it was said in https://community.jboss.org/thread/173486

      Could someone please help me and give me a hint what could still be wrong.