9 Replies Latest reply on Aug 27, 2012 1:33 PM by Tomaz Cerar

    Does jboss-as-maven-plugin not support Java 7

    Randahl Fink Isaksen Novice

      With the new Oracle Java 7 for Mac out I dedided to upgrade my projects to run on Java 7. It turns out that this upgrade makes my deployment process fail. I am using the jboss-as-maven-plugin, and it has worked just fine up until now, but now I get this error:


      Failed to execute goal org.jboss.as.plugins:jboss-as-maven-plugin:7.1.1.Final:deploy (default) on project wefend-server: Error executing FORCE_DEPLOY: Could not execute operation '{

      "operation" => "read-children-names",

      "child-type" => "deployment"

      }': java.net.ConnectException: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out

      -> [Help 1]


      The strange thing is I did not get this error when running on Java 1.6. I am certain that JBoss is in fact listening on port 9999 because the log contains this line


      15:03:44,786 INFO  [org.jboss.as.remoting] (MSC service thread 1-23) JBAS017100: Listening on /



      I am trying to deploy using this plugin configuration (which worked on Java 1.6):