4 Replies Latest reply: May 15, 2012 6:39 AM by Hans-Dieter Mader RSS

    Problem: Configuration MS Access DataSource JDBC-ODBC driver (sun.jdbc.odbc.jdbcodbcdriver, AS7.1.1, windows)

    Hans-Dieter Mader Newbie

      Hi,

      I have got problems using a ms access database datasource.

      It simply does not work.

      Here is the message during restart:

       

      JBAS014775:    New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.jdbcodbc (missing) dependents:

                [service jboss.data-source.java:/comp/env/jdbc/accessDb]

       

      I did a lot research but now I got stuck... Please help!!

      Any ideas higly appreciated.

       

      Hans-Dieter

       

      Config: ../standalone.xml

       

      ...

      <datasource jta="false" jndi-name="java:/comp/env/jdbc/accessDb" pool-name="accessDb_Pool"

           enabled="true" use-java-context="true" use-ccm="true">

       

           <connection-url>"jdbc:odbc:Driver={Microsoft Access Driver (*.mdb, *.accdb)};DBQ=\\path\MAPS_MFA_ERG07.accdb"</connection-url>

           <driver>jdbcodbc</driver>

       

      </datasource>

      ...

      <drivers>

           <driver name="jdbcodbc" module="josf3.sun.jdbc.odbc"/>

      </drivers>

       

       

      Config: ..modules/josf3/sun/jdbc/odbc/main/main.xml

       

      <?xml version="1.0" encoding="UTF-8"?>

      <module xmlns="urn:jboss:module:1.1" name="josf3.sun.jdbc.odbc">

          <dependencies>

              <system export="true">

                  <paths>

                      <path name="sun/jdbc/odbc"/>

                      <path name="sun/jdbc/odbc/ee"/>

                  </paths>

              </system>

          </dependencies>

      </module>