2 Replies Latest reply on May 15, 2012 7:50 AM by ashutosh malik

    problem while configure Jboss 5.1 cluster on two different linux system

    ashutosh malik Newbie

      Hi all,

       

       

                   I am trying to set up two jboss 5.1 cluster on two defferent linux system.

                   there is a firewall working beetween them.

                

       

                  Step 1.1 : changes made in server.xml  1st linux system (change in default http and ajp port )


                          

                     <Connector protocol="HTTP/1.1" port="8181" address="${jboss.bind.address}" connectionTimeout="20000" redirectPort="8443" />

            

                     <Connector protocol="AJP/1.3" port="8019" address="${jboss.bind.address}" redirectPort="8443" />

       

                     <Engine name="jboss.web" defaultHost="localhost" jvmRoute="node3" >

       

       

                  Step 1.2 : start jboss 5.1 on first linux machine using following ...

       

                   ./run.sh -c all -g DocsPartition -u 239.255.100.100 -b 10.1.2.23 -Djboss.messaging.ServerPeerID=2 -Djboss.service.binding.set=ports-01

       

          

                  Step 2.1 : changes made in server.xml  2nd linux system (change in default http and ajp port)

       

                          

                     <Connector protocol="HTTP/1.1" port="8181" address="${jboss.bind.address}" connectionTimeout="20000" redirectPort="8443" />

            

                     <Connector protocol="AJP/1.3" port="8019" address="${jboss.bind.address}" redirectPort="8443" />

       

                     <Engine name="jboss.web" defaultHost="localhost" jvmRoute="node4" >

       


                  Step 2 : start jboss 5.1 on other linux machine using following ...

                  

                    ./run.sh -c all -g DocsPartition -u 239.255.100.100 -b 10.1.2.26 -Djboss.messaging.ServerPeerID=1 -Djboss.service.binding.set=ports-01

       

            

       

                 my problem is i am getting following error on 1st linux system jboss console ...

       

       

                             13:13:19,669 WARN  [NAKACK] 10.1.2.23:41540] discarded message from non-member 10.1.2.26:42561, my view is [10.1.2.23:41540|0] [10.1.2.23:41540]

                             13:13:19,915 WARN  [NAKACK] 10.1.2.23:41540] discarded message from non-member 10.1.2.26:42561, my view is [10.1.2.23:41540|0] [10.1.2.23:41540]

                             13:13:26,866 WARN  [NAKACK] 10.1.2.23:41540] discarded message from non-member 10.1.2.26:42561, my view is [10.1.2.23:41540|0] [10.1.2.23:41540]

                             13:13:27,211 WARN  [NAKACK] 10.1.2.23:41540] discarded message from non-member 10.1.2.26:42561, my view is [10.1.2.23:41540|0] [10.1.2.23:41540]

       

       

             

                    please help me to understand,  what i am doing wrong ...

                  

                     PFA boot.log and server.log file for both instance.