We have loads of new exceptions instead of exception codes. Which is good. However wouldn't it be better to have them all named HornetQ***Exception?
For instance, there is a java.lang.IllegalStateException, and another 4 other exceptions named IllegalStateException available in the classpath of HornetQ. Wouldn't it be better to have a "HornetQIllegalStateException" instead of a 6th IllegalStateException?