6 Replies Latest reply on May 18, 2012 7:36 AM by Kumar Ponmaheswaran

    JBOSS source code build failure

    Kumar Ponmaheswaran Newbie

      Hi all,

      I am building the JBOSS7.1.3 source code on my windows 7 OS . when i build the source code using maven3.0.4 i am getting th error like

       

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.

      12:test (default-test) on project jboss-as-connector: There are test failures.

      [ERROR]

      [ERROR] Please refer to E:\JBoss-FIles\JBOSS_SOURCE\jbossas-jboss-as-6eba711\con

      nector\target\surefire-reports for the individual test results.

      [ERROR] -> [Help 1]

      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal o

      rg.apache.maven.plugins:maven-surefire-plugin:2.12:test (default-test) on projec

      t jboss-as-connector: There are test failures.

       

       

      Please refer to E:\JBoss-FIles\JBOSS_SOURCE\jbossas-jboss-as-6eba711\connector\t

      arget\surefire-reports for the individual test results.

              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor

      .java:213)

              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor

      .java:153)

              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor

      .java:145)

              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje

      ct(LifecycleModuleBuilder.java:84)

              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje

      ct(LifecycleModuleBuilder.java:59)

              at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBu

      ild(LifecycleStarter.java:183)

              at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(Lifecycl

      eStarter.java:161)

              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)

              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)

              at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)

              at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)

              at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.

      java:39)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces

      sorImpl.java:25)

              at java.lang.reflect.Method.invoke(Method.java:597)

              at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Laun

      cher.java:290)

              at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav

      a:230)

              at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La

      uncher.java:409)

              at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:

      352)

      Caused by: org.apache.maven.plugin.MojoFailureException: There are test failures

      .

       

      I googled it this exception and error but still there is no solution i found.

       

      some body has told the forum mention the version of surfire-plugin .According to that i mentioned the surfire version as 2.12 in the pom.xml of connector

       

      but still the error continue..........

       

       

      Please help to go forward ....

       

       

      Thanks,

      Mahes

        • 1. Re: JBOSS source code build issue
          Narayanan Swaminathan Newbie

          Hi Mahes,

           

          Try to reinstall maven and try.Moreover check whether maven version is compatible with ur JBoss version.

           

          Narayanan

          • 2. Re: JBOSS source code build issue
            Kumar Ponmaheswaran Newbie

            thanks for the reply narayan.

             

            the current maven verion only i am using

             

            i gave lot of "mvn clean" and i rebuild it lot

             

            but there is no positive solution

            • 3. Re: JBOSS source code build issue
              Kumar Ponmaheswaran Newbie

              I tried to build the JBOSS source code using ANT build tool,it is giving error like below

               

              BUILD FAILED

              E:\JBoss-FIles\JBOSS_SOURCE\jbossas-jboss-as-6eba711\build\build.xml:25: The fol

              lowing error occurred while executing this line:

              E:\JBoss-FIles\JBOSS_SOURCE\jbossas-jboss-as-6eba711\build\lib.xml:34: taskdef c

              lass org.jboss.jandex.JandexAntTask cannot be found

              using the classloader AntClassLoader[]

               

               

              How to resolve this error?

              anybody have an idea please let me share....

              • 4. Re: JBOSS source code build issue
                Tomaz Cerar Master

                Kumar,

                 

                try building with running command

                 

                build.bat clean install -DskipTests

                 

                from source root.

                 

                 

                --

                tomaz

                • 5. Re: JBOSS source code build issue
                  Kumar Ponmaheswaran Newbie

                  Tomaz thanks for your reply.

                   

                  Accoring to this command we need to skip the test cases while building parallelly ....

                   

                  because of this any serious issues will come in future?

                   

                   

                  please .......

                  • 6. Re: JBOSS source code build issue
                    Kumar Ponmaheswaran Newbie

                    Hi Tomaz I tried according to your suggestion

                    that error has gone but i got one error i.e compilation error

                     

                     

                    [INFO] BUILD FAILURE

                    [INFO] ------------------------------------------------------------------------

                    [INFO] Total time: 9:58.997s

                    [INFO] Finished at: Fri May 18 17:01:33 IST 2012

                    [INFO] Final Memory: 169M/345M

                    [INFO] ------------------------------------------------------------------------

                    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.

                    3.2:compile (default-compile) on project jboss-as-arquillian-protocol-jmx: Compi

                    lation failure

                    [ERROR] \JBoss-FIles\JBOSS_SOURCE\jbossas-jboss-as-6eba711\arquillian\protocol-j

                    mx\src\main\java\org\jboss\as\arquillian\protocol\jmx\ArquillianServiceDeployer.

                    java:[60,79] inconvertible types

                    [ERROR] found   : org.jboss.shrinkwrap.api.Archive<capture#229 of ?>

                    [ERROR] required: org.jboss.shrinkwrap.api.spec.JavaArchive

                    [ERROR] -> [Help 1]

                    [ERROR]

                    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit

                    ch.

                    [ERROR] Re-run Maven using the -X switch to enable full debug logging.

                    [ERROR]

                    [ERROR] For more information about the errors and possible solutions, please rea

                    d the following articles:

                    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureExc

                    eption

                    [ERROR]

                    [ERROR] After correcting the problems, you can resume the build with the command

                     

                    [ERROR]   mvn <goals> -rf :jboss-as-arquillian-protocol-jmx

                     

                     

                     

                    Please help me if you know about this issue.